summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Talipov2021-03-08 15:31:44 +0500
committerMarat Talipov2021-03-08 15:31:44 +0500
commitd9cb37176f499b00e23d60b9dbf5e812181bf490 (patch)
treee5195fc63e92f094283247fa9be269a5ee32149b
downloadaur-d9cb37176f499b00e23d60b9dbf5e812181bf490.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--google-sheets-nativefier.desktop8
-rw-r--r--google-sheets-nativefier.pngbin0 -> 27128 bytes
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85ac28c4d907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = google-sheets-nativefier
+ pkgdesc = Electron wrapper for the Google Sheets web application
+ pkgver = 1
+ pkgrel = 1
+ url = https://sheets.google.com
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs
+ makedepends = nodejs-nativefier
+ makedepends = npm
+ makedepends = unzip
+ source = google-sheets-nativefier.png
+ source = google-sheets-nativefier.desktop
+ sha256sums = 0f785ccbb8d20eb21d81ac60cc85a0c84a84872dbaa9ca1563b3cbc093db399a
+ sha256sums = fe9f908b7adb52f844762e2c3741802dc9b3bf13f9f059d9c819f562f988a624
+
+pkgname = google-sheets-nativefier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31107235a47b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Marat Talipov <t-marat@yandex.ru>
+# Based on package "google-docs-nativefier"
+
+pkgname=google-sheets-nativefier
+pkgver=1
+pkgrel=1
+pkgdesc="Electron wrapper for the Google Sheets web application"
+arch=(x86_64)
+license=(MIT)
+url=https://sheets.google.com
+source=($pkgname.png
+ $pkgname.desktop)
+makedepends=(nodejs nodejs-nativefier npm unzip)
+sha256sums=('0f785ccbb8d20eb21d81ac60cc85a0c84a84872dbaa9ca1563b3cbc093db399a'
+ 'fe9f908b7adb52f844762e2c3741802dc9b3bf13f9f059d9c819f562f988a624')
+
+_instname=GoogleSheets
+
+build() {
+ nativefier "https://sheets.google.com/" \
+ --icon $pkgname.png \
+ --maximize \
+ --name "$_instname" \
+ --user-agent "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" \
+ --internal-urls "(.*?shetts\.google\.com.*?|.*?accounts\.google\.com.*?)" \
+ --single-instance \
+ --electron-version 8.2.0
+}
+
+package() {
+ install -d "$pkgdir"/opt "$pkgdir"/usr/{bin,share/pixmaps}
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$_instname.desktop
+
+ cp -rL $_instname-linux-* "$pkgdir"/opt/$pkgname
+ ln -sf /opt/$pkgname/$_instname "$pkgdir"/usr/bin/$_instname
+ ln -sf /opt/$pkgname/resources/app/icon.png "$pkgdir"/usr/share/pixmaps/$_instname.png
+
+ chmod 666 "$pkgdir"/opt/$pkgname/resources/app/nativefier.json
+} \ No newline at end of file
diff --git a/google-sheets-nativefier.desktop b/google-sheets-nativefier.desktop
new file mode 100644
index 000000000000..b3172cce2da3
--- /dev/null
+++ b/google-sheets-nativefier.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Google Sheets
+Comment=With Google Sheets, you can write, edit, and collaborate wherever you are. For Free.
+Exec=GoogleSheets
+Icon=/usr/share/pixmaps/GoogleSheets.png
+Terminal=false
+Categories=Productivity;Sheets;Google;Nativefier; \ No newline at end of file
diff --git a/google-sheets-nativefier.png b/google-sheets-nativefier.png
new file mode 100644
index 000000000000..2203864c6012
--- /dev/null
+++ b/google-sheets-nativefier.png
Binary files differ