summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-04 01:08:26 +0200
committerNarrat2018-06-04 01:08:59 +0200
commit8f3e9a1bcca5d65e6534b492fd479c927b0477e2 (patch)
tree22b5ba7e080be68241b2c79ee65e3303aafb6b87
parentb3ccfa54bd80d8381a7aa1a9b60e787875009352 (diff)
downloadaur-googlecl.tar.gz
googlecl: Add missing deps
and make the name of the downloaded archive unique. And remove python from deps. This program isn't compatible with python3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f704ba5a3ca2..b40854daa21d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = googlecl
pkgdesc = Command line utility to use google services
pkgver = 0.9.15
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vinitkumar/googlecl
arch = any
license = APACHE
- depends = python
depends = python2
- source = https://github.com/vinitkumar/googlecl/archive/v0.9.15.tar.gz
+ depends = python2-gdata
+ depends = python2-httplib2
+ depends = python2-oauth2client
+ source = googlecl-0.9.15.tar.gz::https://github.com/vinitkumar/googlecl/archive/v0.9.15.tar.gz
md5sums = 76c96871c69ec1272b31e808cb0a3cac
pkgname = googlecl
diff --git a/PKGBUILD b/PKGBUILD
index fbcef9065ea6..5c67cf2864db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: Justin R. St-Amant <jstamant24 at gmail dot com>
+# Contributor: Justin R. St-Amant <jstamant24 at gmail dot com>
# Contributor: Mikael Eriksson <mikael_eriksson@miffe.org>
pkgname=googlecl
pkgver=0.9.15
-pkgrel=1
+pkgrel=2
pkgdesc="Command line utility to use google services"
arch=('any')
url="https://github.com/vinitkumar/googlecl"
license=('APACHE')
-depends=('python'
- 'python2')
-source=(https://github.com/vinitkumar/googlecl/archive/v0.9.15.tar.gz)
+depends=('python2' 'python2-gdata' 'python2-httplib2' 'python2-oauth2client')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/vinitkumar/${pkgname}/archive/v${pkgver}.tar.gz)
md5sums=('76c96871c69ec1272b31e808cb0a3cac')
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
python2 setup.py install --prefix=/usr --root=$pkgdir
install -Dm644 docs/man/google.1 "$pkgdir/usr/share/man/man1/google.1"
}