summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin R. St-Amant2015-10-23 23:43:38 -0500
committerJustin R. St-Amant2015-10-23 23:43:38 -0500
commit9d7199d8463b540a19c1baee8b6fff7bb21ae833 (patch)
treed1924a44c5c711b9c94ffdb611bee02d56dde5f4
downloadaur-9d7199d8463b540a19c1baee8b6fff7bb21ae833.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c87900408849
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = googlecl-git
+ pkgdesc = Command line utility to use google services
+ pkgver = 0.9.15
+ pkgrel = 1
+ url = https://github.com/vinitkumar/googlecl
+ arch = any
+ license = APACHE
+ makedepends = git
+ depends = python
+ depends = python2
+ provides = googlecl
+ conflicts = googlecl
+ source = googlecl-git::git+https://github.com/vinitkumar/googlecl.git
+ md5sums = SKIP
+
+pkgname = googlecl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f67334ce814
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Justin R. St-Amant <jstamant24 at gmail dot com>
+pkgname=googlecl-git
+pkgver=0.9.15
+pkgrel=1
+pkgdesc="Command line utility to use google services"
+arch=('any')
+url="https://github.com/vinitkumar/googlecl"
+license=('APACHE')
+depends=('python'
+ 'python2')
+makedepends=('git')
+provides=('googlecl')
+conflicts=('googlecl')
+source=("$pkgname::git+https://github.com/vinitkumar/googlecl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ rm src/google
+ python2 setup.py install --prefix=/usr --root=$pkgdir
+ install -Dm644 docs/man/google.1 "$pkgdir/usr/share/man/man1/google.1"
+}