summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-08 09:27:38 -0700
committerMark Wagie2021-03-08 09:27:38 -0700
commit462fa9299cd87b0a5159cc3f41215a99a96e4b6c (patch)
treea806e74e87f1cfdfb93d336b59afabd843b5cef5
parentb9aa0c6890fd9c128fb5a3ffa2fd8d75854f0b47 (diff)
downloadaur-462fa9299cd87b0a5159cc3f41215a99a96e4b6c.tar.gz
1.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2b303421f76..8db4e2c220c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = googledot-cursor-theme
pkgdesc = Cursor theme inspired on Google
- pkgver = 1.0.1
+ pkgver = 1.1.0
pkgrel = 1
url = https://www.pling.com/p/1215613
arch = any
@@ -8,11 +8,11 @@ pkgbase = googledot-cursor-theme
makedepends = python-clickgen
depends = libxcursor
depends = libpng
- noextract = googledot-cursor-theme-bitmaps-1.0.1.zip
- source = googledot-cursor-theme-1.0.1.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v1.0.1.tar.gz
- source = googledot-cursor-theme-bitmaps-1.0.1.zip::https://github.com/ful1e5/Google_Cursor/releases/download/v1.0.1/bitmaps.zip
- sha256sums = 5eaaa21cb96e9c310d78dbb577e4c1109f6aa5e96c0dc054abb6c7b097a4a2cf
- sha256sums = 61c0bff15a77cacf5367c5172bfe5014af258cfa9fbfa5df5c65f8d3aea095c5
+ noextract = googledot-cursor-theme-bitmaps-1.1.0.zip
+ source = googledot-cursor-theme-1.1.0.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v1.1.0.tar.gz
+ source = googledot-cursor-theme-bitmaps-1.1.0.zip::https://github.com/ful1e5/Google_Cursor/releases/download/v1.1.0/bitmaps.zip
+ sha256sums = c0082299be26a1f157c5beb71f1957c978747a044347ce44fcbd28ade5751ea5
+ sha256sums = fa16d5db8ba80df7c1f8b4d59647785fbfc8818717fdca05f051d75d458a9da1
pkgname = googledot-cursor-theme
diff --git a/PKGBUILD b/PKGBUILD
index b47cb6691f9b..8aea97eee9bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=googledot-cursor-theme
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc="Cursor theme inspired on Google"
arch=('any')
@@ -11,22 +11,26 @@ makedepends=('python-clickgen')
source=("$pkgname-$pkgver.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v$pkgver.tar.gz"
"$pkgname-bitmaps-$pkgver.zip::https://github.com/ful1e5/Google_Cursor/releases/download/v$pkgver/bitmaps.zip")
noextract=("$pkgname-bitmaps-$pkgver.zip")
-sha256sums=('5eaaa21cb96e9c310d78dbb577e4c1109f6aa5e96c0dc054abb6c7b097a4a2cf'
- '61c0bff15a77cacf5367c5172bfe5014af258cfa9fbfa5df5c65f8d3aea095c5')
+sha256sums=('c0082299be26a1f157c5beb71f1957c978747a044347ce44fcbd28ade5751ea5'
+ 'fa16d5db8ba80df7c1f8b4d59647785fbfc8818717fdca05f051d75d458a9da1')
prepare() {
- cd Google_Cursor-$pkgver
- mkdir -p bitmaps
- bsdtar -xf "$srcdir/$pkgname-bitmaps-$pkgver.zip" -C bitmaps
+ cd Google_Cursor-$pkgver
+ mkdir -p bitmaps
+ bsdtar -xf "$srcdir/$pkgname-bitmaps-$pkgver.zip" -C bitmaps
}
build() {
cd Google_Cursor-$pkgver/builder
- python build.py unix
+ _themes='Blue Black'
+
+ for t in $_themes; do
+ python build.py unix -p "../bitmaps/GoogleDot-$t"
+ done
}
package() {
cd Google_Cursor-$pkgver
install -d "$pkgdir/usr/share/icons"
- cp -r themes/GoogleDot "$pkgdir/usr/share/icons"
+ cp -r themes/GoogleDot-* "$pkgdir/usr/share/icons"
}