summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2017-08-02 19:11:45 -1000
committerGaetan Bisson2017-08-02 19:11:45 -1000
commite74eeb7e11a9e5ee86431f18ac9385436c5d3362 (patch)
treea1dc98b43a0933320d1c42da860fffe6dace76b3
downloadaur-e74eeb7e11a9e5ee86431f18ac9385436c5d3362.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0b6ba6b9e00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = googlemaps
+ pkgdesc = Google Maps plugin for QtLocation
+ pkgver = 20170802.6715783
+ pkgrel = 1
+ url = https://github.com/vladest/googlemaps
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-location
+ source = git+https://github.com/vladest/googlemaps
+ sha256sums = SKIP
+
+pkgname = googlemaps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a64c60b5744c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=googlemaps
+pkgver=20170802.6715783
+pkgrel=1
+pkgdesc='Google Maps plugin for QtLocation'
+url='https://github.com/vladest/googlemaps'
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('git' 'qt5-tools')
+depends=('qt5-location')
+source=('git+https://github.com/vladest/googlemaps')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ install -d build
+ cd build
+ qmake ../googlemaps.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ cd build
+ make INSTALL_ROOT="${pkgdir}" install
+}