summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2021-11-11 18:50:57 +0100
committerfordprefect2021-11-11 18:50:57 +0100
commitb251720379d2ce2fcd0b4a3a9241082d1256d072 (patch)
treebdf37de0b9ff8b8ada88e42544047a3ae5d7e79b
downloadaur-b251720379d2ce2fcd0b4a3a9241082d1256d072.tar.gz
1.3.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b54eb25ba4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = googleplay
+ pkgdesc = Download APK from Google Play or send API requests
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/89z/googleplay
+ arch = i686
+ arch = x86_64
+ license = OSL
+ makedepends = go
+ source = googleplay-1.3.0.tar.gz::https://github.com/89z/googleplay/archive/refs/tags/v1.3.0.tar.gz
+ md5sums = 139196fec73b6e0916a387a0b0469a60
+
+pkgname = googleplay
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98e991cb5004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=googleplay
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Download APK from Google Play or send API requests"
+url="https://github.com/89z/googleplay"
+arch=('i686' 'x86_64')
+license=('OSL')
+depends=()
+makedepends=("go")
+#optdepends=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/89z/googleplay/archive/refs/tags/v1.3.0.tar.gz")
+md5sums=('139196fec73b6e0916a387a0b0469a60')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p build/
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./cmd/...
+
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm444 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}