summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Arias2018-03-25 13:12:39 +0200
committerPablo Arias2018-03-25 13:12:39 +0200
commitbbf54eaf99762fc2983c2a5ff1305ed281cbf2b2 (patch)
tree59cc9cfb58821efe6320c048a3b2a6b8a464bbaf
parent69240adafa7f424e544a3492163b5edf43db40a1 (diff)
downloadaur-bbf54eaf99762fc2983c2a5ff1305ed281cbf2b2.tar.gz
* Reworked PKGBUILD to better arch standars
* Added prepare step that disables auto upgrade
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76f679a3707e..418b0ea26289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: Pablo Arias <pacloariasal@gmail.com>
+# Contributor: John Jenkins <twodopeshaggy@gmail.com>
_pkgname=googler
pkgname=googler-git
-pkgver=r357.360caac
+pkgver=3.5.r4.g2356105
pkgrel=1
-pkgdesc="Google Search from command line"
+pkgdesc="Google from the command-line"
arch=('any')
url="https://github.com/jarun/googler"
license=('GPL3')
@@ -15,9 +16,14 @@ conflicts=('googler')
source=('git://github.com/jarun/googler.git')
md5sums=('SKIP')
+prepare() {
+ cd $srcdir/$_pkgname
+ make disable-self-upgrade > /dev/null
+}
+
pkgver() {
cd $srcdir/$_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/v\([^-]*-\)/\1r/;s/-/./g'
}
package() {