summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmonff2016-07-14 20:35:32 +0200
committersmonff2016-07-14 20:35:32 +0200
commitd8f702f1159623b9ff4e7c9a7a5a943dca05e325 (patch)
tree437baa19caad1b2d9563ac6dd3a528a6cc4ac2e8
downloadaur-d8f702f1159623b9ff4e7c9a7a5a943dca05e325.tar.gz
First version of the package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc5d4dad0e01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gopanda
+ pkgdesc = GoPanda 2 is a modern client to Pandanet that runs in the browser.
+ pkgver = 2
+ pkgrel = 1
+ url = http://pandanet-igs.com/communities/gopanda
+ arch = x86_64
+ license = custom
+ depends = xdg-utils
+ source = http://pandanet-igs.com/gopanda2/installer/stable/linux-64/gopanda2-linux-64.tar.gz
+ md5sums = d1fcd13d8de0f2c0331ee0a9cb58a58a
+
+pkgname = gopanda
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11e32002566b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Sébastien Feugère <smonff@riseup.net>
+pkgname=gopanda
+pkgver=2
+pkgrel=1
+pkgdesc="GoPanda 2 is a modern client to Pandanet that runs in the browser."
+arch=('x86_64')
+url="http://pandanet-igs.com/communities/$pkgname$pkgversion"
+license=('custom')
+depends=('xdg-utils')
+# TODO multi arch script
+source=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-64/$pkgname$pkgver-linux-64.tar.gz")
+md5sums=('d1fcd13d8de0f2c0331ee0a9cb58a58a')
+# Generated using makepkg -g
+
+
+# build() {
+# cd "$srcdir/GoPanda$pkgver"
+# ./configure --prefix=/usr
+# make
+# }
+
+package() {
+ cd "GoPanda2"
+ make DESTDIR="$pkgdir/" install
+
+ # Run the installation script
+ sh "$srcdir/GoPanda2/install.sh"
+
+ # set the installation path...
+ install_path="$HOME/.local/bin/GoPanda2"
+
+ # Write the license to the installation path
+ license_content="GoPanda2 belongs to Pandanet Inc, all rights reserved.\n\nThe software is delivered \"as is\" and we take no responsibility for\nany problems that arise from usage.\n\nGoPanda2 may be redistributed by third parties only when free of\ncharge or advertisements and without modifications to the\nincluded source code or resource files."
+
+
+ echo -e $license_content
+}