summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Klingenberg2020-03-26 19:45:52 +0100
committerDario Klingenberg2020-03-26 19:45:52 +0100
commite95f7a86a927cd06a91994ae72d9771fc65e4d44 (patch)
tree946fa7b9981906970803df73c93ef7ddf00755d8
parent6572a29bad55a504f6f530ff0a906b41198460cf (diff)
downloadaur-e95f7a86a927cd06a91994ae72d9771fc65e4d44.tar.gz
update to current version (now distrbuted as AppImage)
-rw-r--r--PKGBUILD41
1 files changed, 20 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed717da028bf..5a26c4d45d67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,49 @@
# Maintainer: Alex Kubica <alexkubicail@gmail.com>
# Contributor: Sébastien Feugère <smonff@riseup.net>
+# Contributor: Dario Klingenberg <dario.klingenberg at web.de>
pkgname=gopanda
-pkgver=2.5.2
+pkgver=2.6.8
pkgrel=1
pkgdesc="Client for the Pandanet-IGS go Server"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://pandanet-igs.com/communities/gopanda2"
license=('custom')
-depends=('libnotify'
- 'alsa-lib'
- 'libxtst'
- 'gtk2'
- 'gconf'
- 'nss')
+depends=()
options=(!strip)
-source=('LICENSE')
-source_i686=("http://pandanet-igs.com/gopanda2/installer/stable/linux-32/gopanda2-linux-32.tar.gz")
-source_x86_64=("http://pandanet-igs.com/gopanda2/installer/stable/linux-64/gopanda2-linux-64.tar.gz")
-md5sums=('c5951d02adb28f6b333d913ae2f92df0')
-md5sums_i686=('170e380003a712267e3e85c0fe38011a')
-md5sums_x86_64=('d1fcd13d8de0f2c0331ee0a9cb58a58a')
+source_x86_64=("https://pandanet-igs.com/gopanda2/download/GoPanda2.AppImage")
+md5sums_x86_64=('21620c0be7bb21402181ce1e4a7d448c')
_DEST="/opt/${pkgname}"
-_CLIENT="GoPanda2"
+_CLIENT="GoPanda2.AppImage"
+_NAME="GoPanda2"
_DESKTOP="/usr/share/applications/${_CLIENT}.desktop"
-_ICON="/usr/share/pixmaps/${_CLIENT}.png"
+_ICON="/usr/share/pixmaps/${_NAME}.png"
+
+prepare() {
+ chmod u+x "${srcdir}/${_CLIENT}"
+ ./${_CLIENT} --appimage-extract 2> /dev/null
+}
package() {
+
# Copy license
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/squashfs-root/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "$srcdir/${_CLIENT}"
+ cd "$srcdir/"
# Program
install -Dm755 "${_CLIENT}" "${pkgdir}${_DEST}/${_CLIENT}"
- install -m644 nw.pak libffmpegsumo.so icudtl.dat "${pkgdir}${_DEST}"
# Link to program
install -dm755 "${pkgdir}/usr/bin"
ln -s "${_DEST}/${_CLIENT}" "${pkgdir}/usr/bin/${pkgname}"
# Icon
- install -Dm644 "${_CLIENT}.png" "${pkgdir}${_ICON}"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname}2.png" "${pkgdir}${_ICON}"
# Desktop file
- install -Dm644 "${_CLIENT}.orig" "${pkgdir}${_DESKTOP}"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname}2.desktop" "${pkgdir}${_DESKTOP}"
echo "Exec=${_DEST}/${_CLIENT}" >> "${pkgdir}${_DESKTOP}"
echo "Icon=${_ICON}" >> "${pkgdir}${_DESKTOP}"
echo "MimeType=application/x-go-sgf;application/x-go-ugf;application/x-go-ugi;" >> "${pkgdir}${_DESKTOP}"
+ rm -r "${srcdir}/squashfs-root"
}