summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario2021-08-09 16:09:08 +0200
committerDario2021-08-09 16:09:08 +0200
commitffe921be96dca24840d0bcca42d55822e4516128 (patch)
tree7c5251a68952aec5cd55152d70bc1b9d4accb99a
parent4f91c29153b5ae8025878b4febb2813d8c05291c (diff)
downloadaur-ffe921be96dca24840d0bcca42d55822e4516128.tar.gz
introduce a check function for version mismatch
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66c71c505156..1fd213cc13fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,9 +23,21 @@ prepare() {
./${_CLIENT} --appimage-extract 2> /dev/null
}
+check() {
+ MATCH=$(cat ${srcdir}/squashfs-root/gopanda2.desktop | grep X-AppImage-Version=$pkgver || [[ $? == 1 ]])
+ if [[ -z ${MATCH} ]]; then
+ echo "Version check failed! A newer version has been released, but the
+ PKGBUILD has not yet been updated. Change the pkgver and checksums in
+ the PKGUILB yourself and/or leave a comment at
+ https://aur.archlinux.org/packages/gopanda/ so that the PKGBUILD will be
+ updated.";
+ exit 1;
+ fi
+}
+
package() {
- # Copy license
+ # Copy license
install -Dm644 "${srcdir}/squashfs-root/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "$srcdir/"