summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2017-01-02 11:24:42 +0100
committerrevel2017-01-02 11:24:42 +0100
commit20fd9f5539ddf6a2a1a4d21370521ae5e79778da (patch)
tree5f19c7cb053248a733f268bc821a339c10bf98f3
parent4acc4d2222e457a4c2746a6d006bad9541c7a148 (diff)
downloadaur-20fd9f5539ddf6a2a1a4d21370521ae5e79778da.tar.gz
- comply with OpenVPN 2.4.0 changes regarding location of client configuration files
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--config.patch25
3 files changed, 34 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c8f78910615..c5ffcbdabfaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gopenvpn-git
pkgdesc = gopenvpn is a simple graphical front-end for OpenVPN, the open source VPN solution.
pkgver = svn.migration.r12.gb4192eb
- pkgrel = 4
+ pkgrel = 5
url = http://gopenvpn.sourceforge.net/
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = gopenvpn-git
depends = openvpn
optdepends = gnome-keyring: handle credentials
source = gopenvpn-git::git://gopenvpn.git.sourceforge.net/gitroot/gopenvpn/gopenvpn.git
- md5sums = SKIP
+ source = config.patch
+ sha256sums = SKIP
+ sha256sums = 51ec862cbd94c156e247331b357d08da805aaf458e9935dad9198c8a45a31ebc
pkgname = gopenvpn-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c8fb916dd77..6ec6a9fa6534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gopenvpn-git
pkgver=svn.migration.r12.gb4192eb
-pkgrel=4
+pkgrel=5
pkgdesc='gopenvpn is a simple graphical front-end for OpenVPN, the open source VPN solution.'
arch=('i686' 'x86_64')
url='http://gopenvpn.sourceforge.net/'
@@ -11,9 +11,9 @@ depends=('libglade' 'libgnome-keyring' 'gtk2' 'openvpn')
optdepends=('gnome-keyring: handle credentials')
makedepends=('git')
source=("$pkgname"::'git://gopenvpn.git.sourceforge.net/gitroot/gopenvpn/gopenvpn.git'
- )
-md5sums=('SKIP'
- )
+ 'config.patch')
+sha256sums=('SKIP'
+ '51ec862cbd94c156e247331b357d08da805aaf458e9935dad9198c8a45a31ebc')
pkgver() {
cd "$pkgname"
@@ -26,6 +26,7 @@ prepare() {
sed -i "/ACLOCAL_AMFLAGS = -I m4/d" Makefile.am
sed -i "s/AM_GNU_GETTEXT_VERSION(\[0\.18\.1\])/AM_GNU_GETTEXT_VERSION([0.19])/g" configure.ac
sed -i "s/\/usr\/sbin\/openvpn/\/usr\/bin\/openvpn/g" polkit/net.openvpn.gui.gopenvpn.policy
+ patch -p1 -i ../config.patch
}
build() {
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..2f81515db666
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,25 @@
+diff -ruN 1/src/gopenvpn.c 2/src/gopenvpn.c
+--- 1/src/gopenvpn.c 2017-01-02 10:59:59.000000000 +0100
++++ 2/src/gopenvpn.c 2017-01-02 11:13:23.000000000 +0100
+@@ -1350,8 +1350,8 @@
+ glob_t gl;
+ int i;
+
+- glob("/etc/openvpn/*.conf", 0, NULL, &gl);
+- glob("/etc/openvpn/*.ovpn", GLOB_APPEND, NULL, &gl);
++ glob("/etc/openvpn/client/*.conf", 0, NULL, &gl);
++ glob("/etc/openvpn/client/*.ovpn", GLOB_APPEND, NULL, &gl);
+
+ applet->configs_count = gl.gl_pathc;
+
+diff -ruN 1/src/gopenvpn.h 2/src/gopenvpn.h
+--- 1/src/gopenvpn.h 2017-01-02 10:59:59.000000000 +0100
++++ 2/src/gopenvpn.h 2017-01-02 11:12:45.000000000 +0100
+@@ -27,6 +27,6 @@
+
+ #define GLADE_FILE "gopenvpn.glade"
+
+-#define CONFIG_PATH "/etc/openvpn"
++#define CONFIG_PATH "/etc/openvpn/client"
+
+ #define MAX_RETRY 10