summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-07-22 17:52:23 +0200
committerSimon Legner2018-07-22 17:52:23 +0200
commit02b01e41446930d8743ea9fe135358726e991b46 (patch)
treec2edfbbe800e65dc8c1920b22e55e049a26ac922
downloadaur-02b01e41446930d8743ea9fe135358726e991b46.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53b21ad2b6d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = goproxy
+ pkgdesc = A high performance HTTP, HTTPS, websocket, TCP, UDP, Secure DNS, Socks5 proxy server
+ pkgver = 5.2
+ pkgrel = 1
+ url = https://github.com/snail007/goproxy
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ makedepends = dep
+ makedepends = git
+ source = goproxy-5.2.tar.gz::https://github.com/snail007/goproxy/archive/v5.2.tar.gz
+ sha256sums = 7a7b00dfa48fe0e2e4d18a99f08c31f2bf744c9c73e3dd69396ff87b08521217
+
+pkgname = goproxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4132542c9693
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=goproxy
+pkgver=5.2
+pkgrel=1
+pkgdesc="A high performance HTTP, HTTPS, websocket, TCP, UDP, Secure DNS, Socks5 proxy server"
+arch=('x86_64')
+url="https://github.com/snail007/goproxy"
+license=('GPL3')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/snail007/$pkgname/archive/v$pkgver.tar.gz")
+makedepends=('go' 'dep' 'git')
+
+_importpath="github.com/snail007/$pkgname"
+
+prepare() {
+ export GOPATH="$srcdir/_go"
+ mkdir -p $(dirname "$GOPATH/src/$_importpath")
+ ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_importpath"
+ cd "$GOPATH/src/$_importpath"
+ dep ensure -v
+}
+
+check() {
+ export GOPATH="$srcdir/_go"
+ cd "$GOPATH/src/$_importpath"
+ go test $(go list ./...)
+}
+
+build() {
+ export GOPATH="$srcdir/_go"
+ cd "$GOPATH/src/$_importpath"
+ go build
+}
+
+package() {
+ export GOPATH="$srcdir/_go"
+ cd "$GOPATH/src/$_importpath"
+ install -dm755 "$pkgdir/usr/bin"
+ install -m755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+sha256sums=('7a7b00dfa48fe0e2e4d18a99f08c31f2bf744c9c73e3dd69396ff87b08521217')