summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-08-08 12:33:34 +0600
committerKirill Isakov2023-08-08 12:33:34 +0600
commitda464a4e25e16de894ddf0a3024d870602ad4f28 (patch)
tree32e8008f8930a31a61286c3db9a76a90326a65ab
downloadaur-da464a4e25e16de894ddf0a3024d870602ad4f28.tar.gz
Initial upload: goread 1.5.2-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78841103eb18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = goread
+ pkgdesc = Read RSS/Atom feeds right in the terminal
+ pkgver = 1.5.2
+ pkgrel = 1
+ url = https://github.com/TypicalAM/goread
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = riscv64
+ license = GPL3
+ makedepends = go
+ depends = glibc
+ source = goread-1.5.2.tar.gz::https://github.com/TypicalAM/goread/archive/refs/tags/v1.5.2.tar.gz
+ sha256sums = 4967c0ba8bb02b13ab0c13b2b89f2b67559908896749eaa0e59470c19af93743
+
+pkgname = goread
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb242805f5c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cb8227f1426
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: tarball <bootctl@gmail.com>
+
+pkgname=goread
+pkgver=1.5.2
+pkgrel=1
+pkgdesc='Read RSS/Atom feeds right in the terminal'
+url='https://github.com/TypicalAM/goread'
+arch=(i686 x86_64 aarch64 riscv64)
+license=(GPL3)
+makedepends=(go)
+depends=(glibc)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('4967c0ba8bb02b13ab0c13b2b89f2b67559908896749eaa0e59470c19af93743')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p build
+ go mod download
+}
+
+build() {
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS='-buildmode=pie -trimpath -mod=readonly -modcacherw'
+
+ cd "$srcdir/$pkgname-$pkgver"
+ go build -o $pkgname
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # binary
+ install -Dm755 $pkgname \
+ "$pkgdir/usr/bin/$pkgname"
+
+ # license
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}