summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-24 08:13:52 +0300
committerDimitris Kiziridis2020-04-24 08:13:52 +0300
commitfe3f67af407fa063520f936b1841adf479950b37 (patch)
tree8b1e6c52f30d55758b3794dc6ff2424801a51082
downloadaur-fe3f67af407fa063520f936b1841adf479950b37.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b566cfba2859
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = goreplay-bin
+ pkgdesc = An open-source tool for capturing and replaying live HTTP traffic into a test environment in order to continuously test your system with real data. It can be used to increase confidence in code deployments, configuration changes and infrastructure changes
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://goreplay.org
+ arch = x86_64
+ license = LGPL-3.0
+ provides = goreplay
+ source = https://github.com/buger/goreplay/releases/download/v1.0.0/gor_1.0.0_x64.tar.gz
+ sha256sums = 631b92e63b5f8757beb1b0f80298dcc7dbd991435c419f64156a68e89e8ab162
+
+pkgname = goreplay-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d6c2a5447a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=goreplay-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="An open-source tool for capturing and replaying live HTTP traffic into a test environment in order to continuously test your system with real data. It can be used to increase confidence in code deployments, configuration changes and infrastructure changes"
+arch=('x86_64')
+url='https://goreplay.org'
+license=('LGPL-3.0')
+provides=("${pkgname%-bin}")
+source=("https://github.com/buger/goreplay/releases/download/v${pkgver}/gor_${pkgver}_x64.tar.gz")
+sha256sums=('631b92e63b5f8757beb1b0f80298dcc7dbd991435c419f64156a68e89e8ab162')
+
+package() {
+ install -Dm755 "${srcdir}/gor" \
+ "${pkgdir}/usr/bin/gor"
+} \ No newline at end of file