summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtluna2019-03-30 15:41:00 +0300
committerdtluna2019-03-30 15:41:00 +0300
commit1a282ef7899b724147bdc6ec2f1a644d2c2b3c16 (patch)
treeacd957c45777bd0528af7ce3e4d3ca8df935fa7d
downloadaur-1a282ef7899b724147bdc6ec2f1a644d2c2b3c16.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c8643663701
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gorgeous-bin
+ pkgdesc = CLI RSS feed reader
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://git.dtluna.net/dtluna/gorgeous
+ arch = x86_64
+ arch = i686
+ license = custom:WTFPL
+ conflicts = gorgeous
+ source_x86_64 = gorgeous-bin_1.4.0_linux_x86_64.zip::https://git.dtluna.net/attachments/ff15f6ad-537b-466f-9ccd-487cff0c71d2
+ sha256sums_x86_64 = bf346274f5facdfe848fdf43edeebeddde2b92b2460ecd01b022c8f25d0b1ac8
+ source_i686 = gorgeous-bin_1.4.0_linux_i686.zip::https://git.dtluna.net/attachments/390c0796-9632-42e3-8bc2-06ad33d80b1a
+ sha256sums_i686 = c8e820d7009d89491ff3c1d5686b36f3fa80f9c6140f52cadeb53035732ea9a1
+
+pkgname = gorgeous-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b8cb1258fb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: dtluna <dtluna at waifu dot club>
+
+_pkgname_base='gorgeous'
+pkgname="${_pkgname_base}-bin"
+pkgver='1.4.0'
+pkgrel=1
+pkgdesc='CLI RSS feed reader'
+url='https://git.dtluna.net/dtluna/gorgeous'
+arch=('x86_64' 'i686')
+license=('custom:WTFPL')
+
+depends=()
+makedepends=()
+optdepends=()
+
+conflicts=("${_pkgname_base}")
+
+source_x86_64=("${pkgname}_${pkgver}_linux_x86_64.zip::https://git.dtluna.net/attachments/ff15f6ad-537b-466f-9ccd-487cff0c71d2")
+source_i686=("${pkgname}_${pkgver}_linux_i686.zip::https://git.dtluna.net/attachments/390c0796-9632-42e3-8bc2-06ad33d80b1a")
+
+sha256sums_x86_64=('bf346274f5facdfe848fdf43edeebeddde2b92b2460ecd01b022c8f25d0b1ac8')
+sha256sums_i686=('c8e820d7009d89491ff3c1d5686b36f3fa80f9c6140f52cadeb53035732ea9a1')
+
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${_pkgname_base}"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname_base}/LICENSE"
+}
+