summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhaofeng Li2019-08-04 18:51:54 -0700
committerZhaofeng Li2019-08-04 18:52:35 -0700
commitd51bc1bf38708225fc4ae4a081ee473ddedb82c0 (patch)
tree7383b3d0a1051a8724e95234e20336c710fdf07d
downloadaur-d51bc1bf38708225fc4ae4a081ee473ddedb82c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD38
-rw-r--r--gortr.env1
-rw-r--r--gortr.service12
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e24e8bfd5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gortr-bin
+ pkgdesc = An RPKI-to-Router server written in Go
+ pkgver = 0.11.3
+ pkgrel = 1
+ url = https://github.com/cloudflare/gortr
+ arch = x86_64
+ license = BSD
+ provides = gortr
+ conflicts = gortr
+ backup = etc/conf.d/gortr
+ source = gortr::https://github.com/cloudflare/gortr/releases/download/v0.11.3/gortr-v0.11.3-linux-x86_64
+ source = https://github.com/cloudflare/gortr/releases/download/v0.11.3/cf.pub
+ source = https://github.com/cloudflare/gortr/raw/v0.11.3/LICENSE.txt
+ source = gortr.env
+ source = gortr.service
+ md5sums = f7586dcf627dfe80c09571dc1e495f30
+ md5sums = b196196f8598b43023d86821929197e1
+ md5sums = b0725559434e18b352046f9b15619960
+ md5sums = b8eb3dab8494b7d031249b7d4ae5a5ba
+ md5sums = 67afd99e5c49c253c8d531d30d1f4f59
+
+pkgname = gortr-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb31db0c0529
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*~
+*.tar.gz
+*.pkg.tar.*
+/gortr
+/cf.pub
+/LICENSE.txt
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf64bbbf9901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zhaofeng Li <hello@zhaofeng.li>
+
+pkgname=gortr-bin
+pkgver=0.11.3
+pkgrel=1
+pkgdesc="An RPKI-to-Router server written in Go"
+arch=('x86_64')
+url="https://github.com/cloudflare/gortr"
+license=('BSD')
+depends=()
+provides=('gortr')
+conflicts=('gortr')
+backup=(
+ 'etc/conf.d/gortr'
+)
+source=(
+ "gortr::https://github.com/cloudflare/gortr/releases/download/v${pkgver}/gortr-v${pkgver}-linux-x86_64"
+ "https://github.com/cloudflare/gortr/releases/download/v${pkgver}/cf.pub"
+ "https://github.com/cloudflare/gortr/raw/v${pkgver}/LICENSE.txt"
+ 'gortr.env'
+ 'gortr.service'
+)
+
+md5sums=('f7586dcf627dfe80c09571dc1e495f30'
+ 'b196196f8598b43023d86821929197e1'
+ 'b0725559434e18b352046f9b15619960'
+ 'b8eb3dab8494b7d031249b7d4ae5a5ba'
+ '67afd99e5c49c253c8d531d30d1f4f59')
+
+package() {
+ install -Dm755 "${srcdir}/gortr" "${pkgdir}/usr/bin/gortr"
+ install -Dm644 "${srcdir}/gortr.env" "${pkgdir}/etc/conf.d/gortr"
+ install -Dm644 "${srcdir}/gortr.service" "${pkgdir}/usr/lib/systemd/system/gortr.service"
+ install -Dm644 "${srcdir}/cf.pub" "${pkgdir}/usr/lib/gortr/cf.pub"
+ install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gortr.env b/gortr.env
new file mode 100644
index 000000000000..7f81bdcb8025
--- /dev/null
+++ b/gortr.env
@@ -0,0 +1 @@
+GORTR_ARGS=
diff --git a/gortr.service b/gortr.service
new file mode 100644
index 000000000000..002d418ef935
--- /dev/null
+++ b/gortr.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=GoRTR
+After=network.target
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/conf.d/gortr
+WorkingDirectory=/usr/lib/gortr
+ExecStart=/usr/bin/gortr $GORTR_ARGS
+
+[Install]
+WantedBy=multi-user.target