summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:48:02 +0200
committerAlexander F Rødseth2015-06-10 14:48:02 +0200
commit40f280e138f36bdf8e7ae478d27268c8ca2790c2 (patch)
tree42eb24166dab0af7f01fab0114901d8cfba5e64e
downloadaur-40f280e138f36bdf8e7ae478d27268c8ca2790c2.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95e65de1e614
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gorun
+ pkgdesc = Program to run Go programs as if they were scripts
+ pkgver = 19
+ pkgrel = 2
+ url = http://launchpad.net/gorun/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = go
+ options = !strip
+ source = http://bazaar.launchpad.net/~niemeyer/gorun/trunk/download/head:/gorun.go-20110311220116-kde0kha0feljz1pm-3/gorun.go
+ sha256sums = a5655571c1e89c267e14ce8f6944f9f4e88e13ecef7783c8a9b4eb21f94bd4cf
+
+pkgname = gorun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9f873770239
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=gorun
+pkgver=19
+pkgrel=2
+pkgdesc="Program to run Go programs as if they were scripts"
+arch=('x86_64' 'i686')
+url="http://launchpad.net/gorun/"
+license=('GPL3')
+makedepends=('go')
+options=(!strip)
+source=("http://bazaar.launchpad.net/~niemeyer/gorun/trunk/download/head:/gorun.go-20110311220116-kde0kha0feljz1pm-3/gorun.go")
+sha256sums=('a5655571c1e89c267e14ce8f6944f9f4e88e13ecef7783c8a9b4eb21f94bd4cf')
+
+build() {
+ cd "$srcdir"
+
+ go build -o $pkgname
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: