summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2021-07-23 17:30:08 +0200
committerkleintux2021-07-23 17:30:08 +0200
commita4a8bb8f696f417a90baf3cca8a3785f9a23878a (patch)
treedaee24842baada3da42f3f310838cabb37de6154
downloadaur-a4a8bb8f696f417a90baf3cca8a3785f9a23878a.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa3c6c9279bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gosimac
+ pkgdesc = Fetch the wallpaper from Bings, Unsplash...
+ pkgver = 4.1.1
+ pkgrel = 1
+ url = https://github.com/1995parham/
+ arch = any
+ license = GPL2
+ conflicts = gosimac-bin
+ conflicts = gosimac-git
+ source = https://github.com/1995parham//archive/refs/tags/v4.1.1.tar.gz
+ sha256sums = 10895e9455953c6b5b240f9ea805ff6f8975aeac87f97a3163d100e74fb54531
+
+pkgname = gosimac
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e583179f5c36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Parham Alvani <parham.alvani@gmail.com>
+
+pkgname=gosimac
+pkgver=4.1.1
+pkgrel=1
+pkgdesc="Fetch the wallpaper from Bings, Unsplash..."
+arch=('any')
+url="https://github.com/1995parham/${_pkgname}"
+license=('GPL2')
+conflicts=("${pkgname}-bin" "${pkgname}-git")
+
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+
+sha256sums=('10895e9455953c6b5b240f9ea805ff6f8975aeac87f97a3163d100e74fb54531')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ .
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -D -m644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README.md
+}