summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraligator2022-11-12 15:14:59 +0100
committeraligator2022-11-12 15:14:59 +0100
commit54ea9312c9098a2e5fb8095e1123a037199c08e8 (patch)
tree1c055d706b3c83a5448f42e15ed51d003f6c1d2a
parent4042f8b86f236d9d7d34ff0932efdb12456b2478 (diff)
downloadaur-54ea9312c9098a2e5fb8095e1123a037199c08e8.tar.gz
Update to v0.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef329b52e37d..3505238ac6a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = goslice
pkgdesc = An experimental slicer for 3d printing written in Go.
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/aligator/GoSlice
arch = i686
@@ -12,7 +12,7 @@ pkgbase = goslice
arch = aarch64
license = Apache
makedepends = go
- source = goslice-0.4.0.tar.gz::https://github.com/aligator/GoSlice/archive/v0.4.0.tar.gz
- sha512sums = ec5da3d914ca0350d8ff94a21a4c6ee4cd811038b21c5f9e6cfa15d191741fea33295cc8683b4fad70dcd676444bc42ce466e308e8fd73e7cb259322be049867
+ source = goslice-0.5.0.tar.gz::https://github.com/aligator/GoSlice/archive/v0.5.0.tar.gz
+ sha512sums = 2609644bb457aba77fe925b8e64c75ae1725a498d60e4e6f86a800ae8ced9ddf4eec44048f4835c10e6603268a3fbe250ac6199b8b8b4976665d829883053d77
pkgname = goslice
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78c1bc8bba07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+src
+pkg
+*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 7ba706ae4603..e818a7343e78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Maintainer: Johannes Hörmann <aligator@suncraft-server.de>
pkgname=goslice
_pkgname=GoSlice
-pkgver=0.4.0
-# Hash of the commit to pass it as BUILD version (as it's not retrievable without git)
-_pkgverhash=18723ed
+pkgver=0.5.0
pkgrel=1
pkgdesc="An experimental slicer for 3d printing written in Go."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
@@ -13,7 +11,7 @@ makedepends=(
'go'
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/aligator/GoSlice/archive/v${pkgver}.tar.gz")
-sha512sums=('ec5da3d914ca0350d8ff94a21a4c6ee4cd811038b21c5f9e6cfa15d191741fea33295cc8683b4fad70dcd676444bc42ce466e308e8fd73e7cb259322be049867')
+sha512sums=('2609644bb457aba77fe925b8e64c75ae1725a498d60e4e6f86a800ae8ced9ddf4eec44048f4835c10e6603268a3fbe250ac6199b8b8b4976665d829883053d77')
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"