summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraligator2021-05-07 22:35:39 +0200
committeraligator2021-05-07 22:35:39 +0200
commita5a8a2d5b885c67e99ab276788f0847b3cbdb564 (patch)
tree839a1bec9ec63ad396a7201219c7d81ae2760e7c
downloadaur-a5a8a2d5b885c67e99ab276788f0847b3cbdb564.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a2e4978360b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = goslice
+ pkgdesc = An experimental slicer for 3d printing written in Go.
+ pkgver = 0.3.7
+ pkgrel = 1
+ url = https://github.com/aligator/GoSlice
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = AGPL
+ makedepends = go
+ source = goslice-0.3.7.tar.gz::https://github.com/aligator/GoSlice/archive/v0.3.7.tar.gz
+ sha512sums = e9d41bacde15ab1b6e3b05f362ab46bdff387a504555a32909ad0d44fbb45701cd71ff8eda57c07d9af777ea7314df191bb5372b1e107b3f88fb058eaca4b223
+
+pkgname = goslice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a69d72559cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jguer <joaogg3@gmail.com>
+pkgname=goslice
+_pkgname=GoSlice
+pkgver=0.3.7
+# Hash of the commit to pass it as BUILD version (as it's not retrievable without git)
+_pkgverhash=993d1e8
+pkgrel=1
+pkgdesc="An experimental slicer for 3d printing written in Go."
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/aligator/GoSlice"
+license=('AGPL')
+makedepends=(
+ 'go'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/aligator/GoSlice/archive/v${pkgver}.tar.gz")
+sha512sums=('e9d41bacde15ab1b6e3b05f362ab46bdff387a504555a32909ad0d44fbb45701cd71ff8eda57c07d9af777ea7314df191bb5372b1e107b3f88fb058eaca4b223')
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+# These are not working, don't know why
+# export CGO_CFLAGS="${CFLAGS}"
+# export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make VERSION=$pkgver BUILD=$pkgverhash DESTDIR="$pkgdir" PREFIX="/usr" build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make VERSION=$pkgver BUILD=$pkgverhash DESTDIR="$pkgdir" PREFIX="/usr" install
+}