summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2022-04-20 17:45:08 +0000
committergoreleaserbot2022-04-20 17:45:08 +0000
commit763f7441b3d0ce84ec85bc502a75495e42a92f5d (patch)
tree742d208da74bad3ff9189d0075a835d6942841f3
parentc9f9f8a3085af9035f19ee8349b94e041ad75e11 (diff)
downloadaur-763f7441b3d0ce84ec85bc502a75495e42a92f5d.tar.gz
Update to 0.0.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62d6ad301407..5ffcb830a8ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = gosmee-bin
pkgdesc = Gosmee - smee.io forwarder in go
- pkgver = 0.0.6
+ pkgver = 0.0.7
pkgrel = 1
url = https://github.com/chmouel/gosmee
license = Apache 2.0
conflicts = gosmee
provides = gosmee
arch = aarch64
- source_aarch64 = https://github.com/chmouel/gosmee/releases/download/0.0.6/gosmee_0.0.6_Linux_arm64.tar.gz
- sha256sums_aarch64 = dd412db4c91a749d4e83ad122fcd0f9550e1233405b8f028eb00088a0f6c640e
+ source_aarch64 = https://github.com/chmouel/gosmee/releases/download/0.0.7/gosmee_0.0.7_Linux_arm64.tar.gz
+ sha256sums_aarch64 = eb7795bb4f7bbc55285b1906a2d9ee51b99da07c5439af812c8af0dc701d57a3
arch = x86_64
- source_x86_64 = https://github.com/chmouel/gosmee/releases/download/0.0.6/gosmee_0.0.6_Linux_x86_64.tar.gz
- sha256sums_x86_64 = 30e31b6498b07e70a7ba36b89751d6a2c3c15f2148ce0c5e4c0c153af25f6ebb
+ source_x86_64 = https://github.com/chmouel/gosmee/releases/download/0.0.7/gosmee_0.0.7_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 066abe93d5d32b560bd89130979dfeace980885655735d370b1c5e8018fb492c
pkgname = gosmee-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6a448f57ac81..ee6a8fff4c6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Chmouel Boudjnah <chmouel@chmouel.com>
pkgname='gosmee-bin'
-pkgver=0.0.6
+pkgver=0.0.7
pkgrel=1
pkgdesc='Gosmee - smee.io forwarder in go'
url='https://github.com/chmouel/gosmee'
@@ -11,12 +11,26 @@ license=('Apache 2.0')
provides=('gosmee')
conflicts=('gosmee')
-source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/chmouel/gosmee/releases/download/0.0.6/gosmee_0.0.6_Linux_arm64.tar.gz")
-sha256sums_aarch64=('dd412db4c91a749d4e83ad122fcd0f9550e1233405b8f028eb00088a0f6c640e')
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/chmouel/gosmee/releases/download/0.0.7/gosmee_0.0.7_Linux_arm64.tar.gz")
+sha256sums_aarch64=('eb7795bb4f7bbc55285b1906a2d9ee51b99da07c5439af812c8af0dc701d57a3')
-source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/chmouel/gosmee/releases/download/0.0.6/gosmee_0.0.6_Linux_x86_64.tar.gz")
-sha256sums_x86_64=('30e31b6498b07e70a7ba36b89751d6a2c3c15f2148ce0c5e4c0c153af25f6ebb')
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/chmouel/gosmee/releases/download/0.0.7/gosmee_0.0.7_Linux_x86_64.tar.gz")
+sha256sums_x86_64=('066abe93d5d32b560bd89130979dfeace980885655735d370b1c5e8018fb492c')
package() {
+ # bin
install -Dm755 "./gosmee" "${pkgdir}/usr/bin/gosmee"
+
+ # license
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/gosmee/LICENSE"
+
+ # completions
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
+ mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
+
+ ./gosmee completion zsh > gosmee.zsh
+ ./gosmee completion bash > gosmee.bash
+
+ install -Dm644 "gosmee.bash" "${pkgdir}/usr/share/bash-completion/completions/gosmee"
+ install -Dm644 "gosmee.zsh" "${pkgdir}/usr/share/zsh/site-functions/_gosmee"
}