summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjohnstondev2023-01-08 23:03:12 -0800
committerjjohnstondev2023-01-08 23:03:12 -0800
commit7f001aa8945e33905950b9473eba374dae1e2f2b (patch)
treef73a13df5cfdbc91b834864866612270d6684347
downloadaur-7f001aa8945e33905950b9473eba374dae1e2f2b.tar.gz
initial push for gospt
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..514164ca864b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gospt
+ pkgdesc = Spotify TUI and CLI written in Go
+ pkgver = 0.0.1
+ pkgrel = 1
+ epoch = 1
+ url = https://gitea.asdf.cafe/abs3nt/gospt
+ arch = x86_64
+ arch = amd64
+ license = GPL
+ source = https://gitea.asdf.cafe/abs3nt/gospt/releases/download/v0.0.1/gospt
+ sha256sums = 86edafaed5464860306ca255defad9390c30222ccf030ee06bf080cefe2d7e68
+
+pkgname = gospt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d75f12699bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: abs3nt <abs3nt@asdf.cafe>
+pkgname="gospt"
+pkgver=0.0.1
+pkgrel=1
+epoch=1
+pkgdesc="Spotify TUI and CLI written in Go"
+arch=("x86_64" "amd64")
+url="https://gitea.asdf.cafe/abs3nt/gospt"
+license=('GPL')
+depends=()
+source=(
+ "https://gitea.asdf.cafe/abs3nt/gospt/releases/download/v${pkgver}/gospt"
+)
+package() {
+ install -Dm755 gospt "${pkgdir}"/usr/bin/gospt
+}
+sha256sums=('86edafaed5464860306ca255defad9390c30222ccf030ee06bf080cefe2d7e68')