summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjohnstondev2023-01-09 16:05:35 -0800
committerjjohnstondev2023-01-09 16:05:35 -0800
commitbcd92baebfc03c4f6574383b0820e92919a538d6 (patch)
tree86b6c656dffbc362a04692449f61ec278d8c4487
parent82c1d81c3e96e53268893d7b6d04fbd57a9cafd8 (diff)
downloadaur-bcd92baebfc03c4f6574383b0820e92919a538d6.tar.gz
refactor
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29b960ee095b..6431d7f4dc60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gospt
pkgdesc = Spotify TUI And CLI written in Go
- pkgver = 0.0.3
+ pkgver = 0.0.5
pkgrel = 1
url = https://gitea.asdf.cafe/abs3nt/gospt
arch = x86_64
license = GPL
makedepends = go
- source = https://gitea.asdf.cafe/abs3nt/gospt/archive/v0.0.3.tar.gz
- sha256sums = 0f47f157680df65dcded6fa8815ad4339eef13e6e922327f0e3134b1f9abbbaf
+ source = https://gitea.asdf.cafe/abs3nt/gospt/archive/v0.0.5.tar.gz
+ sha256sums = 391bccbf432c11c0744aa401db8bb796203f900b6714b1c851cc28ea015845bd
pkgname = gospt
diff --git a/PKGBUILD b/PKGBUILD
index 3c2289912dcf..4d698f2e7526 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=gospt
-pkgver=0.0.3
+pkgver=0.0.5
pkgrel=1
pkgdesc='Spotify TUI And CLI written in Go'
arch=('x86_64')
@@ -7,7 +7,7 @@ url="https://gitea.asdf.cafe/abs3nt/$pkgname"
license=('GPL')
makedepends=('go')
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('0f47f157680df65dcded6fa8815ad4339eef13e6e922327f0e3134b1f9abbbaf')
+sha256sums=('391bccbf432c11c0744aa401db8bb796203f900b6714b1c851cc28ea015845bd')
prepare(){
cd "$pkgname"
@@ -22,6 +22,9 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o build ./...
+ ./build/$pkgname completion zsh > build/gospt_zsh
+ ./build/$pkgname completion bash > build/gospt_bash
+ ./build/$pkgname completion fish > build/gospt_fish
}
check() {
@@ -32,4 +35,9 @@ check() {
package() {
cd "$pkgname"
install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 build/gospt_zsh "$pkgdir"/usr/share/zsh/site-functions/_gospt
+ install -Dm644 build/gospt_bash "$pkgdir"/usr/share/bash-completion/completions/gospt
+ install -Dm644 build/gospt_fish "$pkgdir"/usr/share/fish/vendor_completions.d/gospt.fish
+
+
}