summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabs3nt2023-03-11 21:43:32 -0800
committerabs3nt2023-03-11 21:43:32 -0800
commitf60abf609b0eb8e90c70dc76774e17d40f97361e (patch)
treef1b25d585fdc955601cc6c1e24cd8b277dc805f0
parent8ff5f2b2289f36df98d3c785ca358ec34eeae128 (diff)
downloadaur-gospt-git.tar.gz
update build command
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dcf16135fb0..f1a5ac0c31d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build .
+ go build -buildmode=pie -trimpath -ldflags="-linkmode=external -s -w -X 'git.asdf.cafe/abs3nt/gospt/src.cmd.Version=v${pkgver}'" -mod=readonly -modcacherw .
./gospt completion zsh > gospt_zsh
./gospt completion bash > gospt_bash
./gospt completion fish > gospt_fish