summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjohnstondev2023-01-09 19:26:00 -0800
committerjjohnstondev2023-01-09 19:26:00 -0800
commit5c8c3d388a32103082f8a87c9226a5992b9a7b6a (patch)
tree2aa99f9c68973f25f282720d1e034292def01487
downloadaur-5c8c3d388a32103082f8a87c9226a5992b9a7b6a.tar.gz
initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cdbffad05c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gospt-git
+ pkgdesc = Spotify TUI And CLI written in Go
+ pkgver = 0.0.7.r1.gdcfc0d4
+ pkgrel = 1
+ url = https://gitea.asdf.cafe/abs3nt/gospt
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ provides = gospt
+ source = git+https://gitea.asdf.cafe/abs3nt/gospt.git
+ sha256sums = SKIP
+
+pkgname = gospt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07fad2f2264a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=gospt-git
+pkgver=0.0.7.r1.gdcfc0d4
+pkgrel=1
+pkgdesc='Spotify TUI And CLI written in Go'
+arch=('x86_64')
+url="https://gitea.asdf.cafe/abs3nt/gospt"
+license=('GPL')
+provides=(gospt)
+conflict=(gospt)
+makedepends=('go')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd gospt
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build .
+ ./gospt completion zsh > gospt_zsh
+ ./gospt completion bash > gospt_bash
+ ./gospt completion fish > gospt_fish
+}
+
+package() {
+ cd "gospt"
+ install -Dm755 gospt "$pkgdir"/usr/bin/gospt
+ install -Dm644 gospt_zsh "$pkgdir"/usr/share/zsh/site-functions/_gospt
+ install -Dm644 gospt_bash "$pkgdir"/usr/share/bash-completion/completions/gospt
+ install -Dm644 gospt_fish "$pkgdir"/usr/share/fish/vendor_completions.d/gospt.fish
+}