summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquantulr2020-08-19 20:37:35 +0800
committerquantulr2020-08-19 20:37:35 +0800
commitbe5fc9015bc7110b6e537170b83bb1d2c81c2486 (patch)
tree84d0d83bfdaf8431ac70e6b0db8b35bf522c6361
downloadaur-be5fc9015bc7110b6e537170b83bb1d2c81c2486.tar.gz
v0.1.6
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3dfa5e0d486
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gossa
+ pkgdesc = a fast and simple multimedia fileserver
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/pldubouilh/gossa
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = gossa
+ conflicts = gossa-bin
+ source = gossa-0.1.6::git+https://github.com/pldubouilh/gossa#tag=v0.1.6
+ sha256sums = SKIP
+
+pkgname = gossa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ef069d3d2fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: quantulr <quantulr at gmail dot com>
+
+pkgname=gossa
+pkgdesc="a fast and simple multimedia fileserver"
+pkgver=0.1.6
+pkgrel=1
+arch=('x86_64' 'armv7h' 'aarch64')
+license=('MIT')
+url='https://github.com/pldubouilh/gossa'
+provides=('gossa')
+conflicts=('gossa-bin')
+makedepends=('git' 'go')
+source=("${pkgname}-${pkgver}::git+https://github.com/pldubouilh/gossa#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ git submodule update --init --recursive
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 ${pkgname} "$pkgdir"/usr/bin/gossa
+}