summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Poldrack2020-08-10 16:17:04 +0200
committerMoritz Poldrack2020-08-10 16:17:04 +0200
commit89c52f56e077b113cb74e91a5377531e4ffcccef (patch)
tree8f7c445021c1b41ea4ead0548fd44e7b566e4cea
downloadaur-89c52f56e077b113cb74e91a5377531e4ffcccef.tar.gz
created package got
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fa23e27088c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = got
+ pkgdesc = Simple golang package and CLI tool to download large files faster than cURL and Wget!
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/melbahja/got
+ arch = x86_64
+ arch = arm64
+ license = MIT
+ makedepends = go
+ source = https://github.com/melbahja/got/archive/v0.1.1.tar.gz
+ sha256sums = fa55f71c584814d07562d8935c851816cde542e361bbb27b4cffe729a70679fc
+
+pkgname = got
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f08aaa5a00cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=got
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Simple golang package and CLI tool to download large files faster than cURL and Wget!'
+arch=('x86_64' 'arm64')
+url="https://github.com/melbahja/$pkgname"
+license=('MIT')
+makedepends=('go')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('fa55f71c584814d07562d8935c851816cde542e361bbb27b4cffe729a70679fc')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver/cmd/$pkgname"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -o got
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test -v -race ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver/"
+ install -Dm755 "cmd/$pkgname/$pkgname" "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}