summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-01-10 02:08:30 +0100
committerCarl Smedstad2022-01-10 02:10:13 +0100
commit5b4c7b282620ebc96629bdb46f4c5e18f0d92637 (patch)
tree42a90a5de45beda029868dfbd3f2ed09e78ae9d9
parent680d07585c9b4ebc13c1007e3df2e80dfb010d67 (diff)
downloadaur-5b4c7b282620ebc96629bdb46f4c5e18f0d92637.tar.gz
Update to version 3.10.0 and take over maintenance
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 26 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20785cd1aefb..f98e30f405ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = gotask-taskfile
pkgdesc = A task runner / simpler Make alternative written in Go. Installs as gtask to allow coexistance with taskwarrior.
- pkgver = 3.9.2
+ pkgver = 3.10.0
pkgrel = 1
- url = https://taskfile.dev/
- arch = x86_64
- arch = i686
- arch = aarch64
- arch = armv7h
+ url = https://github.com/go-task/task
+ arch = any
license = MIT
makedepends = go
makedepends = git
provides = gotask-taskfile
conflicts = gotask-taskfile
- source = gotask-taskfile-3.9.2::git://github.com/go-task/task#tag=v3.9.2
- md5sums = SKIP
+ source = gotask-taskfile-3.10.0.tar.gz::https://github.com/go-task/task/archive/refs/tags/v3.10.0.tar.gz
+ sha256sums = 4fb63ffb9e84a4c24b2bde8096a5cfe5d2cd5f340e603a7c9f4b7c11ad967e5a
pkgname = gotask-taskfile
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index b7cc2b49ff8c..0afa936ba884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Jörg Horchler <joerg@horchler.xyz>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Jörg Horchler <joerg@horchler.xyz>
pkgname=gotask-taskfile
-_binname=gtask
-pkgver=3.9.2
+_pkgname=task
+pkgver=3.10.0
pkgrel=1
pkgdesc="A task runner / simpler Make alternative written in Go. Installs as gtask to allow coexistance with taskwarrior."
-arch=('x86_64' 'i686' 'aarch64' 'armv7h')
-url="https://taskfile.dev/"
+arch=('any')
+url="https://github.com/go-task/task"
license=('MIT')
provides=("$pkgname")
conflicts=("$pkgname")
makedepends=('go' 'git')
-source=("${pkgname}-${pkgver}::git://github.com/go-task/task#tag=v${pkgver}")
-md5sums=('SKIP')
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+
+sha256sums=('4fb63ffb9e84a4c24b2bde8096a5cfe5d2cd5f340e603a7c9f4b7c11ad967e5a')
build() {
+ cd "$_pkgname-$pkgver"
+
+ mkdir -p build/
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -22,32 +28,12 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -modcacherw"
- cd "$pkgname-$pkgver"
- _modname=$(awk '$1 == "module" {print $2}' go.mod)
- _mainpath=$(awk '$1 == "main:" {print $2}' .goreleaser.yml | cut -d'/' -f2-)
- _gobinname=$(awk '$1 == "binary:" {print $2}' .goreleaser.yml)
- export _gobinname
-
- mkdir -p build/
- cd build
-
- echo "// +build: main" > main.go
- echo "package main" >> main.go
- echo "" >> main.go
- echo "import _ \"${_modname}/${_mainpath}\"" >> main.go
-
- echo "module ${_gobinname}" > go.mod
- echo "" >> go.mod
- echo "require ${_modname} v${pkgver}" >> go.mod
-
- go mod tidy
- go build -v -o ${_gobinname} -ldflags="-w -s -linkmode=external" ${_modname}/${_mainpath}
+ go build -v -o build ./...
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 build/${_gobinname} "${pkgdir}/usr/bin/${_binname}"
+ cd "$_pkgname-$pkgver"
+
+ install -Dm755 build/task "${pkgdir}/usr/bin/gtask"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 CHANGELOG.md "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}