summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-01-10 02:37:13 +0100
committerCarl Smedstad2022-01-10 02:37:13 +0100
commit730f823fd1de432e19e4aec7b6d6307752132fa8 (patch)
treebbb6ea07bff9cae087cb75943336dda30c84f2a0
parent5b4c7b282620ebc96629bdb46f4c5e18f0d92637 (diff)
downloadaur-730f823fd1de432e19e4aec7b6d6307752132fa8.tar.gz
pkgver 2: Remove git dependency and add check stage
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f98e30f405ab..6367d529ca73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = gotask-taskfile
pkgdesc = A task runner / simpler Make alternative written in Go. Installs as gtask to allow coexistance with taskwarrior.
pkgver = 3.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/go-task/task
arch = any
license = MIT
makedepends = go
- makedepends = git
provides = gotask-taskfile
conflicts = gotask-taskfile
source = gotask-taskfile-3.10.0.tar.gz::https://github.com/go-task/task/archive/refs/tags/v3.10.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0afa936ba884..e220d2c6f7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=gotask-taskfile
_pkgname=task
pkgver=3.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="A task runner / simpler Make alternative written in Go. Installs as gtask to allow coexistance with taskwarrior."
arch=('any')
url="https://github.com/go-task/task"
license=('MIT')
provides=("$pkgname")
conflicts=("$pkgname")
-makedepends=('go' 'git')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
@@ -31,6 +31,12 @@ build() {
go build -v -o build ./...
}
+check() {
+ cd "$_pkgname-$pkgver"
+
+ go test ./...
+}
+
package() {
cd "$_pkgname-$pkgver"