summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Horchler2021-06-13 09:46:16 +0200
committerJörg Horchler2021-06-13 09:46:16 +0200
commit531286b7c33ee2d4989da6237ca592923ff888ef (patch)
tree73cf8ef39ac2100e203b87eb9f7771b18e89f018
downloadaur-531286b7c33ee2d4989da6237ca592923ff888ef.tar.gz
Initial commit.
Signed-off-by: Jörg Horchler <joerg@horchler.xyz>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a7fe98d19a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gotask-taskfile-bin
+ pkgdesc = A task runner / simpler Make alternative written in Go (official binary version). Installs as gtask to allow coexistance with taskwarrior.
+ pkgver = 3.4.3
+ pkgrel = 1
+ url = https://taskfile.dev/
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
+ license = MIT
+ provides = gotask-taskfile
+ conflicts = gotask-taskfile
+ source_x86_64 = https://github.com/go-task/task/releases/download/v3.4.3/task_linux_amd64.tar.gz
+ sha256sums_x86_64 = 1492e0d185eb7e8547136c8813e51189f59c1d9e21e5395ede9b9a40d55c796e
+ source_i686 = https://github.com/go-task/task/releases/download/v3.4.3/task_linux_386.tar.gz
+ sha256sums_i686 = 9a2fe84cfb7a0007360116b69598ba7b1b63ead0ec3ced5f7330864705977f20
+ source_aarch64 = https://github.com/go-task/task/releases/download/v3.4.3/task_linux_arm64.tar.gz
+ sha256sums_aarch64 = d1d56f3fbf54965c0ac5366f8679745f315ca2d4c56f962e73ee8f48bea311ee
+ source_armv7h = https://github.com/go-task/task/releases/download/v3.4.3/task_linux_arm.tar.gz
+ sha256sums_armv7h = 5d96701230abe2ce44ab416674431953e177ad949f8be388646a562876fe7921
+
+pkgname = gotask-taskfile-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2bb01f14583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jörg Horchler <joerg@horchler.xyz>
+
+pkgname=gotask-taskfile-bin
+_pkgname=gotask-taskfile
+pkgver=3.4.3
+pkgrel=1
+pkgdesc="A task runner / simpler Make alternative written in Go (official binary version). Installs as gtask to allow coexistance with taskwarrior."
+arch=('x86_64' 'i686' 'aarch64' 'armv7h')
+url="https://taskfile.dev/"
+license=('MIT')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source_x86_64=("https://github.com/go-task/task/releases/download/v${pkgver}/task_linux_amd64.tar.gz")
+source_i686=("https://github.com/go-task/task/releases/download/v${pkgver}/task_linux_386.tar.gz")
+source_aarch64=("https://github.com/go-task/task/releases/download/v${pkgver}/task_linux_arm64.tar.gz")
+source_armv7h=("https://github.com/go-task/task/releases/download/v${pkgver}/task_linux_arm.tar.gz")
+sha256sums_x86_64=('1492e0d185eb7e8547136c8813e51189f59c1d9e21e5395ede9b9a40d55c796e')
+sha256sums_i686=('9a2fe84cfb7a0007360116b69598ba7b1b63ead0ec3ced5f7330864705977f20')
+sha256sums_aarch64=('d1d56f3fbf54965c0ac5366f8679745f315ca2d4c56f962e73ee8f48bea311ee')
+sha256sums_armv7h=('5d96701230abe2ce44ab416674431953e177ad949f8be388646a562876fe7921')
+
+package() {
+ install -Dm755 "${srcdir}/task" "${pkgdir}/usr/bin/gtask"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/CHANGELOG.md" "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md"
+ install -Dm644 "${srcdir}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+