summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHayden Johnson2023-04-21 14:43:13 -0700
committerHayden Johnson2023-04-21 14:43:13 -0700
commitdf9d73b8f02460f0da3e76682eb1052f7c617c1b (patch)
tree41cc9ea54d9eadc7a70f824053193ab8ae17c479
downloadaur-df9d73b8f02460f0da3e76682eb1052f7c617c1b.tar.gz
version 1.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD41
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc84a7ca7de2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = goterm
+ pkgdesc = Play Go/Baduk/Weiqi in your terminal!
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Chewt/goterm
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/Chewt/goterm/archive/refs/tags/v1.0.tar.gz
+ md5sums = SKIP
+
+pkgname = goterm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dcb7796f0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Hayden Johnson <hajohn100@gmail.com>
+pkgname=goterm
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Play Go/Baduk/Weiqi in your terminal!"
+arch=('x86_64')
+url="https://github.com/Chewt/goterm"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/Chewt/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 -D "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}