summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-08 14:33:10 +1200
committercaltlgin2020-08-08 14:33:10 +1200
commit3ce0278baac5ec4b9b3c363cb48479bc66a844a1 (patch)
tree126300c7d13d0cf1145eea39149a97cc9fb6323f
downloadaur-3ce0278baac5ec4b9b3c363cb48479bc66a844a1.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85ea6a671342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gotify-cli-bin
+ pkgdesc = Command line interface for pushing messages to gotify server
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://github.com/gotify/cli
+ arch = x86_64
+ license = MIT
+ provides = gotify-cli
+ source = gotify-cli-2.1.1::https://github.com/gotify/cli/releases/download/v2.1.1/gotify-cli-linux-amd64
+ source = gotify-cli-2.1.1-README.md::https://raw.githubusercontent.com/gotify/cli/master/README.md
+ source = gotify-cli-2.1.1-LICENSE::https://raw.githubusercontent.com/gotify/cli/master/LICENSE
+ sha256sums = ef7f584b3e253ab4d73cfd602fac5d6ba0fdc4a970c18e5fc3cf560af956e4cd
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gotify-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d4539aa7b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=gotify-cli
+pkgname="${_pkgname}-bin"
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='Command line interface for pushing messages to gotify server'
+arch=('x86_64')
+url='https://github.com/gotify/cli'
+_rawurl="https://raw.githubusercontent.com/${url##*github.com/}"
+license=('MIT')
+provides=("${_pkgname}")
+source=("${_pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/${_pkgname}-linux-amd64"
+ "${_pkgname}-${pkgver}-README.md::${_rawurl}/master/README.md"
+ "${_pkgname}-${pkgver}-LICENSE::${_rawurl}/master/LICENSE")
+sha256sums=('ef7f584b3e253ab4d73cfd602fac5d6ba0fdc4a970c18e5fc3cf560af956e4cd'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ install -Dm755 "${_pkgname}-${pkgver}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${_pkgname}-${pkgver}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: