summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordesbma2021-04-07 22:52:22 +0200
committerdesbma2021-04-07 23:04:42 +0200
commit4e4637320acf288968332fc5dd2716a50dea2d91 (patch)
treedef85e622c7597044136c02806e9f6538e14740f
downloadaur-4e4637320acf288968332fc5dd2716a50dea2d91.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872c45b52f2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gotify-desktop
+ pkgdesc = Small Gotify daemon to send messages as desktop notifications
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/desbma/gotify-desktop
+ arch = x86_64
+ license = GPL
+ makedepends = rust
+ source = gotify-desktop-1.0.0.tar.gz::https://github.com/desbma/gotify-desktop/archive/1.0.0.tar.gz
+ sha512sums = a215a869dae3c7bddd3166c933d91b743db6718b5f8d0583147776eb82fb4915cfe945c34e33cdcdf337718a9bf8c59e81fa6f7eca215feeabb061343447a23a
+
+pkgname = gotify-desktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..533751c57e84
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.tar.zst
+/gotify-desktop*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e7ecd6531fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: desbma
+# shellcheck disable=SC2034,SC2148,SC2154,SC2164
+pkgname=gotify-desktop
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Small Gotify daemon to send messages as desktop notifications '
+arch=('x86_64')
+url="https://github.com/desbma/${pkgname}"
+license=('GPL')
+makedepends=('rust')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/desbma/${pkgname}/archive/${pkgver}.tar.gz")
+sha512sums=('a215a869dae3c7bddd3166c933d91b743db6718b5f8d0583147776eb82fb4915cfe945c34e33cdcdf337718a9bf8c59e81fa6f7eca215feeabb061343447a23a')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release --locked
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm 755 -t "${pkgdir}/usr/bin" ./target/release/${pkgname}
+}