summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-03-11 13:11:30 +0100
committerml2020-03-13 05:10:40 +0100
commit653af15ea59869cff726e7e878ca017460fbaaf7 (patch)
tree8ed2a83d78b1a0a53c3a51d0fd3ce33b9af29db7
parent6eb13edc93780a56ca10c594ab8174fd15a5df72 (diff)
downloadaur-653af15ea59869cff726e7e878ca017460fbaaf7.tar.gz
patch default config paths
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--config.patch36
-rw-r--r--default-port.patch12
-rw-r--r--tmpfiles.d2
5 files changed, 45 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d24b576f4bbd..865d82d76fba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,12 +16,12 @@ pkgbase = gotify-server
source = sysusers.d
source = tmpfiles.d
source = gotify-server.service
- source = default-port.patch
+ source = config.patch
sha256sums = 986125b92192e404a2f3af5db510d2d651c6301d218cbb66edd6013f8e8153b0
sha256sums = 2052ac82ceb607701bd505c9df4170bb65c14601a4c8dda3c4ee36fd399c3dfa
- sha256sums = 6993561f2c31860e7a59850ba5c3aac9a061420f72961fd6488e7608d3e68ff5
- sha256sums = 6220ae0a14147401785c54737f75bd90627cb51cea272e7662d65a63ef5399ca
- sha256sums = 7366c858a766b926c3d698bd31194ef1bab32de2668c9279a56c445f810a5984
+ sha256sums = 181258b6ee9ee9b52b37c9dbf0c17faa786a90a3ea45299819173d5df32f95b0
+ sha256sums = 05b3edff049ad5600c2515279a6e1167dd8e62c2525e3916d807aba35a33362f
+ sha256sums = 6bc218da0fbcf06819f9635b91ae19674d31e9cbf6aafb62c0327d68bdd0dcd3
pkgname = gotify-server
diff --git a/PKGBUILD b/PKGBUILD
index 4dab87a8c3ea..bceb98f496bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,16 +15,16 @@ source=(
'sysusers.d'
'tmpfiles.d'
'gotify-server.service'
- 'default-port.patch'
+ 'config.patch'
)
sha256sums=('986125b92192e404a2f3af5db510d2d651c6301d218cbb66edd6013f8e8153b0'
'2052ac82ceb607701bd505c9df4170bb65c14601a4c8dda3c4ee36fd399c3dfa'
- '6993561f2c31860e7a59850ba5c3aac9a061420f72961fd6488e7608d3e68ff5'
+ '181258b6ee9ee9b52b37c9dbf0c17faa786a90a3ea45299819173d5df32f95b0'
'05b3edff049ad5600c2515279a6e1167dd8e62c2525e3916d807aba35a33362f'
- '7366c858a766b926c3d698bd31194ef1bab32de2668c9279a56c445f810a5984')
+ '6bc218da0fbcf06819f9635b91ae19674d31e9cbf6aafb62c0327d68bdd0dcd3')
prepare() {
- patch -N -p1 -d "server-$pkgver" <default-port.patch
+ patch -N -p1 -d "server-$pkgver" <config.patch
}
build() {
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..e96f9b0de7f2
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,36 @@
+diff -ura package.orig/config.example.yml package.new/config.example.yml
+--- package.orig/config.example.yml 2020-03-08 14:59:02.828681120 +0100
++++ package.new/config.example.yml 2020-03-11 12:51:58.314895932 +0100
+@@ -3,7 +3,7 @@
+
+ server:
+ listenaddr: "" # the address to bind on, leave empty to bind on all addresses
+- port: 80 # the port the HTTP server will listen on
++ port: 8080 # the port the HTTP server will listen on
+
+ ssl:
+ enabled: false # if https should be enabled
+@@ -15,7 +15,7 @@
+ letsencrypt:
+ enabled: false # if the certificate should be requested from letsencrypt
+ accepttos: false # if you accept the tos from letsencrypt
+- cache: data/certs # the directory of the cache from letsencrypt
++ cache: certs # the directory of the cache from letsencrypt
+ hosts: # the hosts for which letsencrypt should request certificates
+ # - mydomain.tld
+ # - myotherdomain.tld
+@@ -31,11 +31,11 @@
+
+ database: # for database see (configure database section)
+ dialect: sqlite3
+- connection: data/gotify.db
++ connection: gotify.db
+
+ defaultuser: # on database creation, gotify creates an admin user
+ name: admin # the username of the default user
+ pass: admin # the password of the default user
+ passstrength: 10 # the bcrypt password strength (higher = better but also slower)
+-uploadedimagesdir: data/images # the directory for storing uploaded images
+-pluginsdir: data/plugins # the directory where plugin resides
++uploadedimagesdir: images # the directory for storing uploaded images
++pluginsdir: plugins # the directory where plugin resides
diff --git a/default-port.patch b/default-port.patch
deleted file mode 100644
index 6f4eda05fdbb..000000000000
--- a/default-port.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ura package.orig/config.example.yml package.new/config.example.yml
---- package.orig/config.example.yml 2020-03-08 14:59:02.828681120 +0100
-+++ package.new/config.example.yml 2020-03-08 15:00:09.321068531 +0100
-@@ -3,7 +3,7 @@
-
- server:
- listenaddr: "" # the address to bind on, leave empty to bind on all addresses
-- port: 80 # the port the HTTP server will listen on
-+ port: 8080 # the port the HTTP server will listen on
-
- ssl:
- enabled: false # if https should be enabled
diff --git a/tmpfiles.d b/tmpfiles.d
index 10636d675302..a449f0dc9e13 100644
--- a/tmpfiles.d
+++ b/tmpfiles.d
@@ -1,3 +1,3 @@
-d /var/lib/gotify/data 0700 gotify gotify
+d /var/lib/gotify 0700 gotify gotify
z /var/lib/gotify 0700 gotify gotify
z /etc/gotify/config.yml 0640 root gotify