summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannis Mattheis2021-10-07 22:35:07 +0200
committerJannis Mattheis2021-10-07 22:35:26 +0200
commit66c3c5ae6b3370ec9d7a6069c5467cf00b8e0063 (patch)
tree1dc1e572a7e668fdce57307a3847c47aa0a2280a
parent2093225f831499723957726bace4d09e7d58ffc0 (diff)
downloadaur-66c3c5ae6b3370ec9d7a6069c5467cf00b8e0063.tar.gz
updpkg: 2.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--config.patch7
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 740c722c56f5..9942309e6cf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gotify-server
pkgdesc = A simple server for sending and receiving messages in real-time per WebSocket.
- pkgver = 2.0.23
+ pkgver = 2.1.0
pkgrel = 1
url = https://gotify.net/
install = gotify-server.install
@@ -16,13 +16,13 @@ pkgbase = gotify-server
depends = glibc
options = emptydirs
backup = etc/gotify/config.yml
- source = gotify-server-2.0.23.tar.gz::https://github.com/gotify/server/archive/v2.0.23.tar.gz
+ source = gotify-server-2.1.0.tar.gz::https://github.com/gotify/server/archive/v2.1.0.tar.gz
source = sysusers.d
source = gotify-server.service
source = config.patch
- sha256sums = 9cfa222f5b799c315031e545bce5747b2c0e9bedc200911d9135df6010ff89fb
+ sha256sums = d05038090dc77b3ebfcf8c8a12dc61b2db629c0e0bcb8c0f692b35481c804fca
sha256sums = 39fc913f205bbb102ba42ce3d419f2feb0f9143f14ccffd242b3cd5f51a8c0de
sha256sums = 9aa04ff9a2981aa885d4f8df7467c4d7722aa12de7ae27376a4a11b559a0d1e2
- sha256sums = 8009ba82fa98bfeeb8c51732d8506afdef4ccfdcd4071be5fcf64af06ae2b1f4
+ sha256sums = a8a511e2b98fa548391a1602fcfa05df0e10fae6f5904cbfc4202566f2dd8265
pkgname = gotify-server
diff --git a/PKGBUILD b/PKGBUILD
index 1dd703d27ae9..388e735ca167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jmattheis <contact AT jmattheis DOT de>
# Contributor: ml <ml@visu.li>
pkgname=gotify-server
-pkgver=2.0.23
+pkgver=2.1.0
pkgrel=1
pkgdesc='A simple server for sending and receiving messages in real-time per WebSocket.'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -18,10 +18,10 @@ source=(
'gotify-server.service'
'config.patch'
)
-sha256sums=('9cfa222f5b799c315031e545bce5747b2c0e9bedc200911d9135df6010ff89fb'
+sha256sums=('d05038090dc77b3ebfcf8c8a12dc61b2db629c0e0bcb8c0f692b35481c804fca'
'39fc913f205bbb102ba42ce3d419f2feb0f9143f14ccffd242b3cd5f51a8c0de'
'9aa04ff9a2981aa885d4f8df7467c4d7722aa12de7ae27376a4a11b559a0d1e2'
- '8009ba82fa98bfeeb8c51732d8506afdef4ccfdcd4071be5fcf64af06ae2b1f4')
+ 'a8a511e2b98fa548391a1602fcfa05df0e10fae6f5904cbfc4202566f2dd8265')
prepare() {
patch -N -p1 -d "server-$pkgver" <config.patch
diff --git a/config.patch b/config.patch
index 662b996e2971..276b902c3fa9 100644
--- a/config.patch
+++ b/config.patch
@@ -19,13 +19,13 @@ diff -ura package.orig/config.example.yml package.new/config.example.yml
hosts: # the hosts for which letsencrypt should request certificates
# - mydomain.tld
# - myotherdomain.tld
-@@ -31,11 +31,11 @@
-
+@@ -42,12 +43,12 @@
+
database: # for database see (configure database section)
dialect: sqlite3
- connection: data/gotify.db
+ connection: /var/lib/gotify/gotify.db
-
+
defaultuser: # on database creation, gotify creates an admin user
name: admin # the username of the default user
pass: admin # the password of the default user
@@ -34,3 +34,4 @@ diff -ura package.orig/config.example.yml package.new/config.example.yml
-pluginsdir: data/plugins # the directory where plugin resides
+uploadedimagesdir: /var/lib/gotify/images # the directory for storing uploaded images
+pluginsdir: /var/lib/gotify/plugins # the directory where plugin resides
+ registration: false # enable registrations