summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannis Mattheis2024-06-23 20:30:39 +0200
committerJannis Mattheis2024-06-23 20:30:39 +0200
commitd0c8c99f86d86796d3fb727c04eb8151b4685790 (patch)
tree30cee39a46848aa5e44ac66b35425bcb4c2f0c41
parent2b3bdee9197013dfe0701017e7d115e2de9e46d5 (diff)
downloadaur-d0c8c99f86d86796d3fb727c04eb8151b4685790.tar.gz
updpkg: 2.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--config.patch12
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16283eac8abe..0b69a439e131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gotify-server
pkgdesc = A simple server for sending and receiving messages in real-time per WebSocket.
- pkgver = 2.4.0
+ pkgver = 2.5.0
pkgrel = 1
url = https://gotify.net/
install = gotify-server.install
@@ -16,13 +16,13 @@ pkgbase = gotify-server
depends = glibc
options = emptydirs
backup = etc/gotify/config.yml
- source = gotify-server-2.4.0.tar.gz::https://github.com/gotify/server/archive/v2.4.0.tar.gz
+ source = gotify-server-2.5.0.tar.gz::https://github.com/gotify/server/archive/v2.5.0.tar.gz
source = sysusers.d
source = gotify-server.service
source = config.patch
- sha256sums = ef217ca84232334ed03dcf30ccb67315a07508e6f5a58a923c01ea197e198226
+ sha256sums = 209eb48ac233ff8d9d67b405c4063cb5a33612688e1e8183ebade2128c69c798
sha256sums = 39fc913f205bbb102ba42ce3d419f2feb0f9143f14ccffd242b3cd5f51a8c0de
sha256sums = 9aa04ff9a2981aa885d4f8df7467c4d7722aa12de7ae27376a4a11b559a0d1e2
- sha256sums = a8a511e2b98fa548391a1602fcfa05df0e10fae6f5904cbfc4202566f2dd8265
+ sha256sums = c251cc61b80968f606df9f9840519456fa5ba5f35ced44f73fda49059ed650b6
pkgname = gotify-server
diff --git a/PKGBUILD b/PKGBUILD
index d4752a20e916..7ea81fbf49a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jmattheis <contact AT jmattheis DOT de>
# Contributor: ml <ml@visu.li>
pkgname=gotify-server
-pkgver=2.4.0
+pkgver=2.5.0
pkgrel=1
pkgdesc='A simple server for sending and receiving messages in real-time per WebSocket.'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -18,10 +18,10 @@ source=(
'gotify-server.service'
'config.patch'
)
-sha256sums=('ef217ca84232334ed03dcf30ccb67315a07508e6f5a58a923c01ea197e198226'
+sha256sums=('209eb48ac233ff8d9d67b405c4063cb5a33612688e1e8183ebade2128c69c798'
'39fc913f205bbb102ba42ce3d419f2feb0f9143f14ccffd242b3cd5f51a8c0de'
'9aa04ff9a2981aa885d4f8df7467c4d7722aa12de7ae27376a4a11b559a0d1e2'
- 'a8a511e2b98fa548391a1602fcfa05df0e10fae6f5904cbfc4202566f2dd8265')
+ 'c251cc61b80968f606df9f9840519456fa5ba5f35ced44f73fda49059ed650b6')
prepare() {
patch -N -p1 -d "server-$pkgver" <config.patch
diff --git a/config.patch b/config.patch
index 276b902c3fa9..d3d45cffbfbb 100644
--- a/config.patch
+++ b/config.patch
@@ -1,16 +1,16 @@
diff -ura package.orig/config.example.yml package.new/config.example.yml
--- package.orig/config.example.yml 2020-03-08 14:59:02.828681120 +0100
+++ package.new/config.example.yml 2020-03-12 02:30:06.273495477 +0100
-@@ -3,7 +3,7 @@
-
+@@ -4,7 +4,7 @@
server:
- listenaddr: "" # the address to bind on, leave empty to bind on all addresses
+ keepaliveperiodseconds: 0 # 0 = use Go default (15s); -1 = disable keepalive; set the interval in which keepalive packets will be sent. Only change this value if you know what you are doing.
+ listenaddr: "" # the address to bind on, leave empty to bind on all addresses. Prefix with "unix:" to create a unix socket. Example: "unix:/tmp/gotify.sock".
- port: 80 # the port the HTTP server will listen on
+ port: 9071 # the port the HTTP server will listen on
-
+
ssl:
enabled: false # if https should be enabled
-@@ -15,7 +15,7 @@
+@@ -16,7 +16,7 @@
letsencrypt:
enabled: false # if the certificate should be requested from letsencrypt
accepttos: false # if you accept the tos from letsencrypt
@@ -19,7 +19,7 @@ diff -ura package.orig/config.example.yml package.new/config.example.yml
hosts: # the hosts for which letsencrypt should request certificates
# - mydomain.tld
# - myotherdomain.tld
-@@ -42,12 +43,12 @@
+@@ -46,12 +46,12 @@
database: # for database see (configure database section)
dialect: sqlite3