summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Girotto2018-08-02 09:43:48 +0200
committerAndrea Girotto2018-08-02 09:43:48 +0200
commit9859ca6278d2201b8d654eef0c11b9733e5100c6 (patch)
tree5763c58d055de5b7c8082f4a753e700bdd03f2ff
parent9f19590fc907f7a08a9d702e6bab43c1d0f12af2 (diff)
downloadaur-9859ca6278d2201b8d654eef0c11b9733e5100c6.tar.gz
Updated PKGBUILD to current active repo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20bfe1e180cc..a0cf34e6a2d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = gotk3-git
pkgdesc = Go bindings for GTK3
- pkgver = 20160809
+ pkgver = r817.d1d3434
pkgrel = 1
- url = https://github.com/conformal/gotk3
+ url = https://github.com/gotk3/gotk3
arch = x86_64
arch = i686
license = ISC
diff --git a/PKGBUILD b/PKGBUILD
index e535b252c46e..0a5e3fb0d038 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
+# Maintainer: Andrea Girotto <andreagirotto+arch at gmail dot com>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=gotk3-git
-pkgver=20160809
+pkgver=r817.d1d3434
pkgrel=1
pkgdesc="Go bindings for GTK3"
arch=('x86_64' 'i686')
-url="https://github.com/conformal/gotk3"
+url="https://github.com/gotk3/gotk3"
license=('ISC')
depends=('go' 'gtk3')
makedepends=('git')
conflicts=('gotk3')
provides=('gotk3')
options=('!strip' '!emptydirs')
-_gourl=github.com/conformal/gotk3
+_gourl=github.com/gotk3/gotk3
+
+pkgver() {
+ cd "$srcdir/src/$_gourl"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
GOPATH="$srcdir" go get -fix -v -x $_gourl/gtk