summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChinmay Dalal2022-04-14 19:55:26 +0530
committerChinmay Dalal2022-04-14 19:55:26 +0530
commit6dcf63f381d2b536082e3aef76199aeb19fdec11 (patch)
tree82a8f6506e0404874e9de7937a00febaed96816e
parent8b3257e150da0a6f80015f8f412dcd85c4fc5591 (diff)
downloadaur-6dcf63f381d2b536082e3aef76199aeb19fdec11.tar.gz
changes suggested by AndyRTR
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d44b796be803..6f74b0398613 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,19 @@
pkgbase = gotktrix-git
pkgdesc = Matrix client in Go and GTK4
- pkgver = r334.f46ae83
- pkgrel = 2
+ pkgver = r361.6e72a40
+ pkgrel = 1
url = https://github.com/diamondburned/gotktrix
arch = x86_64
license = AGPL3
makedepends = go
+ makedepends = git
+ makedepends = cairo
+ makedepends = gobject-introspection
+ makedepends = graphene
+ makedepends = pango
+ makedepends = gdk-pixbuf2
+ depends = gobject-introspection-runtime
+ depends = gtk4
provides = gotktrix
conflicts = gotktrix
source = gotktrix-git::git+https://github.com/diamondburned/gotktrix.git
diff --git a/PKGBUILD b/PKGBUILD
index 8f0e80278535..599f5589e127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Chinmay Dalal <w5vwg64uy@relay.firefox.com>
pkgname=gotktrix-git
license=('AGPL3')
-pkgver=r334.f46ae83
-pkgrel=2
+pkgver=r361.6e72a40
+pkgrel=1
pkgdesc="Matrix client in Go and GTK4"
arch=('x86_64')
url="https://github.com/diamondburned/${pkgname%-git}"
-makedepends=("go")
+makedepends=('go' 'git' 'cairo' 'gobject-introspection' 'graphene' 'pango' 'gdk-pixbuf2')
+depends=('gobject-introspection-runtime' 'gtk4')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=($pkgname::"git+${url}.git")
@@ -18,21 +19,20 @@ pkgver() {
}
build() {
- export GOPATH="$srcdir/go"
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
- -o "${pkgname%-git}" .
+ go build -o "${pkgname%-git}" .
}
package() {
- cd "$srcdir/$pkgname"
- export GOPATH="$srcdir/go"
- echo $PWD
+ cd "$pkgname"
install -Dm755 "$srcdir/$pkgname/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 .nix/com.github.diamondburned.gotktrix.desktop "$pkgdir//usr/share/applications/${pkgname%-git}.desktop"
}