summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-10-26 20:23:41 +1300
committerGeorge Rawlinson2023-10-26 20:23:41 +1300
commit1cb8d48f3cd79e27d8d2969c356fb65cf7eb28ca (patch)
tree00ea8f9e53d8149775a0c291414929650e658415
parent9133e64996b729c051e798a9da02ad0d9fa00f4e (diff)
downloadaur-1cb8d48f3cd79e27d8d2969c356fb65cf7eb28ca.tar.gz
upgpkg: 0.12.1-1
* New upstream release. * Update build process for web assets.
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD9
2 files changed, 56 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..233684d8eb32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = gotosocial
+ pkgdesc = ActivityPub social network server written in Golang
+ pkgver = 0.12.1
+ pkgrel = 1
+ url = https://gotosocial.org
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ makedepends = go
+ makedepends = yarn
+ makedepends = nodejs
+ makedepends = go-swagger
+ depends = glibc
+ options = !lto
+ backup = etc/gotosocial/config.yaml
+ backup = etc/gotosocial/template/404.tmpl
+ backup = etc/gotosocial/template/about.tmpl
+ backup = etc/gotosocial/template/authorize.tmpl
+ backup = etc/gotosocial/template/confirmed.tmpl
+ backup = etc/gotosocial/template/domain-blocklist.tmpl
+ backup = etc/gotosocial/template/email_confirm.tmpl
+ backup = etc/gotosocial/template/email_new_report.tmpl
+ backup = etc/gotosocial/template/email_report_closed.tmpl
+ backup = etc/gotosocial/template/email_reset.tmpl
+ backup = etc/gotosocial/template/email_test.tmpl
+ backup = etc/gotosocial/template/error.tmpl
+ backup = etc/gotosocial/template/finalize.tmpl
+ backup = etc/gotosocial/template/footer.tmpl
+ backup = etc/gotosocial/template/frontend.tmpl
+ backup = etc/gotosocial/template/header.tmpl
+ backup = etc/gotosocial/template/index.tmpl
+ backup = etc/gotosocial/template/oob.tmpl
+ backup = etc/gotosocial/template/profile.tmpl
+ backup = etc/gotosocial/template/sign-in.tmpl
+ backup = etc/gotosocial/template/status.tmpl
+ backup = etc/gotosocial/template/tag.tmpl
+ backup = etc/gotosocial/template/thread.tmpl
+ source = gotosocial::git+https://github.com/superseriousbusiness/gotosocial#commit=5fdc005061c773fda6e0da32abcc6f79ddee80ed
+ source = sysusers.conf
+ source = tmpfiles.conf
+ source = use-fhs-directories.patch
+ sha512sums = SKIP
+ sha512sums = 68890539a1285a819d5a2cd755aeabd59a9872926d9c32e5d54faaf2771414f006e568f2f813f3c6fcd9dbeda7b6e57c924d7490521880cb65632e02fabcbd63
+ sha512sums = b89fad3073e140f17167515b38942e5b5e2bc2aee03c484e1bb7cf6444f86cb1e2a13a60b101e04d22633d348be073ca26cd309da4746e5062c12b4f3ce4b38a
+ sha512sums = 913a5209487aba06bf1d8ac7c02506a05d01a8e12f172666c84bf6870d6237640d4745617b0f07ea8c9dcf665f4e0d24a0aabef31611909f7e9384ed6e7b7e77
+ b2sums = SKIP
+ b2sums = 0a5be7ac18af882c0c89d8e930eb76c2e60bc2c1d5a375ab04e987c7de9a7a3175319c4e5fbc818261141daf5f70d583aebcc2dc197fe3a88047fbfe488ccb94
+ b2sums = 4f65af952441c0f54bb32049a149675e207f8993678423d369c4095c57476464614ac720eccc64d7a93a81268ad7ca41cae75ca7211bd7b78f9035f6e5341f04
+ b2sums = 9edd4520fb99856feb82d01935588add7f805aa180f2ed0fe169cb26576bc2e1d2c1e6ab11604d977cec6a4ad8f1d5be1413e1a366de59b89c5b869136538f8c
+
+pkgname = gotosocial
diff --git a/PKGBUILD b/PKGBUILD
index 628554885253..63ff6d1704df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=gotosocial
-pkgver=0.11.1
+pkgver=0.12.1
pkgrel=1
pkgdesc='ActivityPub social network server written in Golang'
arch=('x86_64')
@@ -37,7 +37,7 @@ backup=(
'etc/gotosocial/template/tag.tmpl'
'etc/gotosocial/template/thread.tmpl'
)
-_commit='c7a46e05dbca86b30123cb1c45c1457bbc7a9c4b'
+_commit='5fdc005061c773fda6e0da32abcc6f79ddee80ed'
source=(
"$pkgname::git+https://github.com/superseriousbusiness/gotosocial#commit=$_commit"
'sysusers.conf'
@@ -98,8 +98,9 @@ build() {
./cmd/...
# generate web assets
- yarn install --cwd web/source
- BUDO_BUILD=1 node web/source
+ yarn --cwd ./web/source install --frozen-lockfile
+ yarn --cwd ./web/source ts-patch install
+ yarn --cwd ./web/source build
}
package() {