summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradmin2024-02-15 20:55:03 +0000
committeradmin2024-02-15 20:55:03 +0000
commit507ece0435eba4d3f3b3207bbb9619d26860070a (patch)
treef316bd7ace7ec93d591d6bb7610d02c78fb6a5b2
parent24441dd0f00b1f4e8528c5cc6b9b5bc01c2dce7b (diff)
downloadaur-507ece0435eba4d3f3b3207bbb9619d26860070a.tar.gz
upgpkg: 0.13.3-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD44
3 files changed, 48 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a95857f2bdc..cfc16b27d547 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = gotosocial
- pkgdesc = ActivityPub social network server written in Golang
- pkgver = 0.13.0
+pkgbase = gotosocial-rc
+ pkgdesc = ActivityPub social network server written in Golang (release candidate)
+ pkgver = 0.13.3
pkgrel = 1
url = https://gotosocial.org
arch = x86_64
@@ -11,6 +11,9 @@ pkgbase = gotosocial
makedepends = nodejs
makedepends = go-swagger
depends = glibc
+ provides = gotosocial
+ conflicts = gotosocial
+ conflicts = gotosocial-git
options = !lto
backup = etc/gotosocial/config.yaml
backup = etc/gotosocial/template/404.tmpl
@@ -35,7 +38,7 @@ pkgbase = gotosocial
backup = etc/gotosocial/template/status.tmpl
backup = etc/gotosocial/template/tag.tmpl
backup = etc/gotosocial/template/thread.tmpl
- source = gotosocial::git+https://github.com/superseriousbusiness/gotosocial#commit=f4fcffc8b56ef73c184ae17892b69181961c15c7
+ source = gotosocial::git+https://github.com/superseriousbusiness/gotosocial#commit=fb3e3ca10dc44cba841019bee1a8812e746133e9
source = sysusers.conf
source = tmpfiles.conf
source = use-fhs-directories.patch
@@ -48,4 +51,4 @@ pkgbase = gotosocial
b2sums = 4f65af952441c0f54bb32049a149675e207f8993678423d369c4095c57476464614ac720eccc64d7a93a81268ad7ca41cae75ca7211bd7b78f9035f6e5341f04
b2sums = 9edd4520fb99856feb82d01935588add7f805aa180f2ed0fe169cb26576bc2e1d2c1e6ab11604d977cec6a4ad8f1d5be1413e1a366de59b89c5b869136538f8c
-pkgname = gotosocial
+pkgname = gotosocial-rc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dcdedb41df2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+gotosocial/
+
+# ---> ArchLinuxPackages
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 9b411692826d..789efe999f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
-# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Maintainer: fossdd <fossdd@pwned.life>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
# Contributor: malacology <guoyizhang at malacology dot net>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname=gotosocial
-pkgver=0.13.0
+pkgname=gotosocial-rc
+_pkgname=${pkgname%-rc}
+pkgver=0.13.3
pkgrel=1
-pkgdesc='ActivityPub social network server written in Golang'
+pkgdesc='ActivityPub social network server written in Golang (release candidate)'
arch=('x86_64')
url='https://gotosocial.org'
license=('AGPL3')
depends=('glibc')
makedepends=('git' 'go' 'yarn' 'nodejs' 'go-swagger')
+provides=("$_pkgname")
+conflicts=("$_pkgname" "$_pkgname-git")
options=('!lto')
backup=(
'etc/gotosocial/config.yaml'
@@ -37,9 +41,9 @@ backup=(
'etc/gotosocial/template/tag.tmpl'
'etc/gotosocial/template/thread.tmpl'
)
-_commit='f4fcffc8b56ef73c184ae17892b69181961c15c7'
+_commit='fb3e3ca10dc44cba841019bee1a8812e746133e9'
source=(
- "$pkgname::git+https://github.com/superseriousbusiness/gotosocial#commit=$_commit"
+ "$_pkgname::git+https://github.com/superseriousbusiness/gotosocial#commit=$_commit"
'sysusers.conf'
'tmpfiles.conf'
'use-fhs-directories.patch'
@@ -54,16 +58,16 @@ b2sums=('SKIP'
'9edd4520fb99856feb82d01935588add7f805aa180f2ed0fe169cb26576bc2e1d2c1e6ab11604d977cec6a4ad8f1d5be1413e1a366de59b89c5b869136538f8c')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
- git describe --tags | sed 's/^v//'
+ git describe --tags | sed 's/^v//' | sed 's/-//g'
}
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
# create directory for build output
- mkdir build
+ mkdir -p build
# download dependencies
export GOPATH="${srcdir}"
@@ -74,7 +78,7 @@ prepare() {
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
# set Go flags
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -105,20 +109,20 @@ build() {
package() {
# systemd integration
- install -vDm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
- install -vDm644 tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
- install -vDm644 "$pkgname/example/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -vDm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
+ install -vDm644 tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
+ install -vDm644 "$_pkgname/example/$_pkgname.service" -t "$pkgdir/usr/lib/systemd/system"
- cd "$pkgname"
+ cd "$_pkgname"
# binary
- install -vDm755 -t "$pkgdir/usr/bin" "build/$pkgname"
+ install -vDm755 -t "$pkgdir/usr/bin" "build/$_pkgname"
# configuration
- install -vDm640 -t "$pkgdir/etc/$pkgname" example/config.yaml
+ install -vDm640 -t "$pkgdir/etc/$_pkgname" example/config.yaml
# web frontend
- install -vd "$pkgdir/usr/share/$pkgname"
- cp -vr web/assets/* "$pkgdir/usr/share/$pkgname"
- cp -vr web/template "$pkgdir/etc/$pkgname"
+ install -vd "$pkgdir/usr/share/$_pkgname"
+ cp -vr web/assets/* "$pkgdir/usr/share/$_pkgname"
+ cp -vr web/template "$pkgdir/etc/$_pkgname"
}