summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2015-06-09 05:25:11 -0400
committerGraeme Gott2015-06-09 05:43:38 -0400
commit417c9b566c2827d351c309243c41c5d86964ad62 (patch)
tree0c84910c0d25cf6c2c82ac0cb150f7489d82bb7a
downloadaur-417c9b566c2827d351c309243c41c5d86964ad62.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--gottet.install11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5212c73e54b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gottet
+ pkgdesc = A tetris clone using the Qt GUI toolkit
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://gottcode.org/gottet/
+ install = gottet.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ source = http://gottcode.org/gottet/gottet-1.1.1-src.tar.bz2
+ sha256sums = c276dba1f7d145d74713fdc92fe2b22cf538ace0115026466109857f7b543163
+
+pkgname = gottet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19f08fd58993
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Graeme Gott <graeme@gottcode.org>
+
+pkgname=gottet
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A tetris clone using the Qt GUI toolkit'
+arch=('i686' 'x86_64')
+url="http://gottcode.org/$pkgname/"
+license=('GPL3')
+depends=('qt5-base')
+install="$pkgname.install"
+source=("http://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha256sums=('c276dba1f7d145d74713fdc92fe2b22cf538ace0115026466109857f7b543163')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/gottet.install b/gottet.install
new file mode 100644
index 000000000000..1c0de2e4fa61
--- /dev/null
+++ b/gottet.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}