summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2021-05-06 15:13:11 -0400
committerGraeme Gott2021-05-06 15:13:11 -0400
commit636c0702a3eaa66d9e07b1a139833542f1f8ec2d (patch)
tree9530c51fc1c67340304db53fcc238866326df9ad
parentaca290f893dc94ef91cd0dc101d5cfd9409c3622 (diff)
downloadaur-636c0702a3eaa66d9e07b1a139833542f1f8ec2d.tar.gz
Update to 1.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92177bd94724..5a83c89d59b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gottet
pkgdesc = A tetris clone using the Qt GUI toolkit
- pkgver = 1.1.9
+ pkgver = 1.2.0
pkgrel = 1
url = https://gottcode.org/gottet/
- arch = i686
arch = x86_64
license = GPL3
- makedepends = qt5-tools
- depends = qt5-base
- source = https://gottcode.org/gottet/gottet-1.1.9-src.tar.bz2
- sha256sums = 6c979caa5b3fa6854ca8367ca0595814fcc101f0bdfad02d64219dd9049abb2b
+ makedepends = cmake
+ makedepends = qt6-tools
+ depends = qt6-base
+ source = https://gottcode.org/gottet/gottet-1.2.0-src.tar.bz2
+ sha256sums = 26647b12258180e46e76413a25b43b2a1c2f9169f0ea039015359ba9fbe4f2f8
pkgname = gottet
diff --git a/PKGBUILD b/PKGBUILD
index 2e3c963d25c6..37817d6d0ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=gottet
-pkgver=1.1.9
+pkgver=1.2.0
pkgrel=1
pkgdesc='A tetris clone using the Qt GUI toolkit'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://gottcode.org/$pkgname/"
license=('GPL3')
-depends=('qt5-base')
-makedepends=('qt5-tools')
+depends=('qt6-base')
+makedepends=('cmake' 'qt6-tools')
source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('6c979caa5b3fa6854ca8367ca0595814fcc101f0bdfad02d64219dd9049abb2b')
+sha256sums=('26647b12258180e46e76413a25b43b2a1c2f9169f0ea039015359ba9fbe4f2f8')
build() {
- cd "$pkgname-$pkgver"
-
- qmake-qt5 PREFIX=/usr
- make
+ cmake -B build -S $pkgbase-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver"
-
- make INSTALL_ROOT="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}