summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAseem Athale2023-07-26 21:45:26 +0530
committerAseem Athale2023-07-26 21:45:26 +0530
commit336ec975fa9f362ec90913083ebc39b29a002fcb (patch)
treeda13ef66e07806365041a8498de456723314704b
downloadaur-336ec975fa9f362ec90913083ebc39b29a002fcb.tar.gz
govarnam-schemes-git: Initial commit
Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD71
-rw-r--r--govarnam-schemes-git.install20
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f9b4f3b5ed4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = govarnam-schemes-git
+ pkgdesc = Transliteration and reverse transliteration for Indian languages - Git version
+ pkgver = 1.8.0.r0.gffde8ee
+ pkgrel = 1
+ url = https://www.varnamproject.com/
+ install = govarnam-schemes-git.install
+ arch = x86_64
+ license = MPL
+ makedepends = python
+ depends = ruby
+ depends = ruby-ffi
+ depends = govarnam
+ provides = govarnam-schemes
+ source = git+https://github.com/varnamproject/schemes.git
+ sha256sums = SKIP
+
+pkgname = govarnam-schemes-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1b9c94bcd3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Aseem Athale <athaleaseem@gmail.com>
+
+_pkgname=schemes
+pkgname=govarnam-schemes-git
+pkgver=1.8.0.r0.gffde8ee
+pkgrel=1
+pkgdesc="Transliteration and reverse transliteration for Indian languages - Git version"
+arch=('x86_64')
+url="https://www.varnamproject.com/"
+license=('MPL')
+makedepends=('python')
+source=("git+https://github.com/varnamproject/${_pkgname}.git")
+sha256sums=('SKIP')
+depends=('ruby' 'ruby-ffi' 'govarnam')
+provides=('govarnam-schemes')
+install=${pkgname}.install
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//g'
+}
+
+build() {
+ cd "${_pkgname}"
+ ruby compile-scheme.rb -s schemes/as/as.scheme -o schemes/as/as.vst
+
+ ruby compile-scheme.rb -s schemes/bn/bn.scheme -o schemes/bn/bn.vst
+
+ ruby compile-scheme.rb -s schemes/gu/gu.scheme -o schemes/gu/gu.vst
+
+ ruby compile-scheme.rb -s schemes/hi/hi.scheme -o schemes/hi/hi.vst
+
+ ruby compile-scheme.rb -s schemes/kn/kn.scheme -o schemes/kn/kn.vst
+
+ ruby compile-scheme.rb -s schemes/ml/ml.scheme -o schemes/ml/ml.vst
+
+ ruby compile-scheme.rb -s schemes/ml-inscript/ml-inscript.scheme -o schemes/ml-inscript/ml-inscript.vst
+
+ ruby compile-scheme.rb -s schemes/mr/mr.scheme -o schemes/mr/mr.vst
+
+ ruby compile-scheme.rb -s schemes/ne/ne.scheme -o schemes/ne/ne.vst
+
+ ruby compile-scheme.rb -s schemes/or/or.scheme -o schemes/or/or.vst
+
+ ruby compile-scheme.rb -s schemes/pa/pa.scheme -o schemes/pa/pa.vst
+
+ ruby compile-scheme.rb -s schemes/sa/sa.scheme -o schemes/sa/sa.vst
+
+ ruby compile-scheme.rb -s schemes/ta/ta.scheme -o schemes/ta/ta.vst
+
+ ruby compile-scheme.rb -s schemes/te/te.scheme -o schemes/te/te.vst
+}
+
+package() {
+ cd "${_pkgname}"
+ mkdir -p "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/as/as.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/bn/bn.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/gu/gu.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/hi/hi.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/kn/kn.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/ml/ml.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/ml-inscript/ml-inscript.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/mr/mr.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/ne/ne.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/or/or.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/pa/pa.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/sa/sa.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/ta/ta.vst "${pkgdir}"/usr/share/varnam/schemes/
+ cp schemes/te/te.vst "${pkgdir}"/usr/share/varnam/schemes/
+}
diff --git a/govarnam-schemes-git.install b/govarnam-schemes-git.install
new file mode 100644
index 000000000000..bdfeea95727f
--- /dev/null
+++ b/govarnam-schemes-git.install
@@ -0,0 +1,20 @@
+post_install(){
+ cat << EOF
+ >>>
+ >>>
+ >>> Basic language scheme support for all languages supported in govarnam has been installed.
+ >>> To import words into govarnam, please ensure that govarnam is installed and
+ >>> run the following command for whichever language you wish to use:
+ >>> varnamcli -s <language_scheme_code> -import /usr/share/varnam/schemes/<language_scheme_code>.vlf
+ >>> For example:
+ >>> varnamcli -s mr -import /usr/share/varnam/schemes/mr.vlf
+ >>>
+ >>>
+ >>>
+ >>>
+EOF
+}
+
+op=$1
+shift
+$op $*