summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Gabriel Gruber2023-12-26 15:51:40 -0300
committerJosé Gabriel Gruber2023-12-26 15:51:40 -0300
commit1f0a1be34987f49cf93b4cf867ebd5bfaa70a884 (patch)
tree5adc99f572ae52ec33c02b959a3f56433ea4ed30
downloadaur-1f0a1be34987f49cf93b4cf867ebd5bfaa70a884.tar.gz
initial of the 64 package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..731a135da3f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gowebly-bin
+ pkgdesc = A language for writing HTML user interfaces in Go.
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://github.com/gowebly/gowebly
+ arch = x86_64
+ license = MIT
+ provides = gowebly
+ conflicts = gowebly
+ source_x86_64 = gowebly-x64-1.10.0.tar.gz::https://github.com/gowebly/gowebly/releases/download/v1.10.0/gowebly_1.10.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 432f1695e6afb4df93927b46673316afdf8f58fce7e33c127ec95b8eada94ca6
+
+pkgname = gowebly-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e99d79e6625
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+*/*
+*.*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a62b19ae57f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: José Gabriel Gruber <development at jgabrielgruber dot dev>
+# Contributor: thdxr (original PKGBUILD)
+# Contributor: Noel Jacob (bun-bin PKGBUILD)
+pkgname=gowebly-bin
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="A language for writing HTML user interfaces in Go."
+arch=('x86_64')
+url="https://github.com/gowebly/gowebly"
+license=('MIT')
+provides=('gowebly')
+conflicts=('gowebly')
+sha256sums_x86_64=("432f1695e6afb4df93927b46673316afdf8f58fce7e33c127ec95b8eada94ca6")
+source_x86_64=("gowebly-x64-${pkgver}.tar.gz::https://github.com/gowebly/gowebly/releases/download/v${pkgver}/gowebly_${pkgver}_linux_amd64.tar.gz")
+build() {
+ install -dm755 "completions"
+ SHELL=zsh "./gowebly" completions > "completions/gowebly.zsh"
+ SHELL=bash "./gowebly" completions > "completions/gowebly.bash"
+ SHELL=fish "./gowebly" completions > "completions/gowebly.fish"
+}
+package() {
+ install -Dm755 "./gowebly" "${pkgdir}/usr/bin/gowebly"
+
+ install -Dm644 completions/gowebly.zsh "${pkgdir}/usr/share/zsh/site-functions/_gowebly"
+ install -Dm644 completions/gowebly.bash "${pkgdir}/usr/share/bash-completion/completions/gowebly"
+ install -Dm644 completions/gowebly.fish "${pkgdir}/usr/share/fish/vendor_completions.d/gowebly.fish"
+}
+