summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 01:54:04 +0300
committerDimitris Kiziridis2020-05-13 01:54:04 +0300
commitf2ffdc5a5c289f1157910e0f129ce085fbf9df26 (patch)
tree191a1a69d66b49dbf63eff3a2e6881068796db45
parent5f13689db4611330d798fa673fe69b02426ca745 (diff)
downloadaur-f2ffdc5a5c289f1157910e0f129ce085fbf9df26.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31c9631258f4..76d1ae757c5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,10 +4,10 @@ pkgbase = goweight-bin
pkgrel = 1
url = https://github.com/jondot/goweight
arch = x86_64
- license = Apache-2.0
+ license = Apache
provides = goweight
- source = https://github.com/jondot/goweight/releases/download/v1.0.5/goweight_1.0.5_Linux_x86_64.tar.gz
- md5sums = 7fee7ed7f4da52605f3fbeccf08b19a5
+ source = goweight-bin-1.0.5.tar.gz::https://github.com/jondot/goweight/releases/download/v1.0.5/goweight_1.0.5_Linux_x86_64.tar.gz
+ sha256sums = d63ec46fd7706a78906d41ea10660224f089b5eb4d4e077c15dc3ad9c6aed7bd
pkgname = goweight-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1a91b28ec03a..05871e576a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ pkgrel=1
pkgdesc='A tool to analyze and troubleshoot a Go binary size'
arch=('x86_64')
url="https://github.com/jondot/goweight"
-license=('Apache-2.0')
+license=('Apache')
provides=('goweight')
-source=("${url}/releases/download/v${pkgver}/goweight_${pkgver}_Linux_x86_64.tar.gz")
-md5sums=('7fee7ed7f4da52605f3fbeccf08b19a5')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/goweight_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('d63ec46fd7706a78906d41ea10660224f089b5eb4d4e077c15dc3ad9c6aed7bd')
package() {
install -Dm755 "${srcdir}"/goweight "${pkgdir}/usr/bin/goweight"
- install -Dm644 "${srcdir}"/LICENSE* "${pkgdir}/usr/share/licenses/goweight/LICENSE"
+ install -Dm644 "${srcdir}"/README.md "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file