summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-21 01:01:35 +0300
committerDimitris Kiziridis2020-05-21 01:01:35 +0300
commit9b5c0e4262d3f6eb083d15446035c4e3bd27d8cc (patch)
tree39440ac228ba074f25be9d099aa17d325bbbafc9
parentcf2c6e89e552397477afa2109657d27e5c12cdb3 (diff)
downloadaur-9b5c0e4262d3f6eb083d15446035c4e3bd27d8cc.tar.gz
update pkgbuild, go-pie replaced
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1d714dbcbb6..16a639f98656 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = goxygen
pkgdesc = Generate a modern Web project with Go, Angular/React/Vue, and MongoDB in seconds
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/Shpota/goxygen
arch = x86_64
license = Apache
- makedepends = go-pie
+ makedepends = go
depends = docker
depends = docker-compose
depends = nodejs
depends = npm
- source = goxygen-0.3.0.tar.gz::https://github.com/Shpota/goxygen/archive/v0.3.0.tar.gz
- sha256sums = c27cc417605adf01cfa46ea869760b0858c0558736b0b416e1b401c4bb2b8005
+ source = goxygen-0.3.1.tar.gz::https://github.com/Shpota/goxygen/archive/v0.3.1.tar.gz
+ sha256sums = SKIP
pkgname = goxygen
diff --git a/PKGBUILD b/PKGBUILD
index 8f4f06129431..cb734e06c835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=goxygen
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Generate a modern Web project with Go, Angular/React/Vue, and MongoDB in seconds"
arch=('x86_64')
@@ -11,29 +11,28 @@ depends=('docker'
'docker-compose'
'nodejs'
'npm')
-makedepends=('go-pie')
+makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('c27cc417605adf01cfa46ea869760b0858c0558736b0b416e1b401c4bb2b8005')
+sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir -p $srcdir/go
- export GOPATH="${srcdir}"/go
- export PATH=$PATH:$GOPATH/bin
- go get -d -v ./...
+ mkdir -p build/
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export GOPATH="${srcdir}"/go
- export PATH=$PATH:$GOPATH/bin
- go build -v -o "../goxygen-bin"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- install -Dm755 ../goxygen-bin "${pkgdir}/usr/bin/goxygen"
+ install -Dm755 build/goxygen "${pkgdir}/usr/bin/goxygen"
install -d "${pkgdir}/usr/share/doc/${pkgname}"
cp -aR templates "${pkgdir}/usr/share/doc/${pkgname}"
- go clean -modcache #Remove go libraries
} \ No newline at end of file