summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2017-10-22 10:35:52 -1000
committerGaetan Bisson2017-10-22 10:35:52 -1000
commit91e331a5f5e19a93ddae54efd379dadcc858f5da (patch)
treee8db7314ebec5473a93b4ec3ef4b43182d5b2a6d
parentc54730781be489983a6f932db4007ec7e582f6d1 (diff)
downloadaur-91e331a5f5e19a93ddae54efd379dadcc858f5da.tar.gz
upstream update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fc8a710e721..f5db01464c30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gp2c
pkgdesc = Translates GP scripts to PARI programs
- pkgver = 0.0.10
+ pkgver = 0.0.10.pl1
pkgrel = 1
url = http://pari.math.u-bordeaux.fr/
arch = i686
@@ -9,8 +9,8 @@ pkgbase = gp2c
license = GPL
makedepends = perl
depends = pari
- source = http://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-0.0.10.tar.gz
- sha1sums = 6bce2bbb69227de44fa768619d1dffa861d6470a
+ source = http://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-0.0.10pl1.tar.gz
+ sha256sums = 5bb12e3b57ed015f955a3639354f871840ef5e0f581c17fa30bbaefe77ab0f9a
pkgname = gp2c
diff --git a/PKGBUILD b/PKGBUILD
index 763764ca4c31..ced4f8718dec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=gp2c
-pkgver=0.0.10
+pkgver=0.0.10.pl1
+_pkgver=${pkgver/.pl/pl}
pkgrel=1
pkgdesc='Translates GP scripts to PARI programs'
url='http://pari.math.u-bordeaux.fr/'
@@ -9,11 +10,11 @@ arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
depends=('pari')
makedepends=('perl')
-source=("${url}pub/pari/GP2C/$pkgname-${pkgver}.tar.gz")
-sha256sums=('e0f89183ae4ea24fc41e1da3df3cca11e4f7061237cee0553082c7806ef917f6')
+source=("${url}pub/pari/GP2C/${pkgname}-${_pkgver}.tar.gz")
+sha256sums=('5bb12e3b57ed015f955a3639354f871840ef5e0f581c17fa30bbaefe77ab0f9a')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_pkgver}"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -24,6 +25,6 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_pkgver}"
make DESTDIR="${pkgdir}" install
}