summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-09-29 02:53:13 +0800
committerChih-Hsuan Yen2018-09-29 02:53:13 +0800
commit555bd455acfbe048cc69c3a991b7d84b2da7a5a4 (patch)
tree9874d78c370df0fb223c44015775f1e71dd8ce4b
parent0ca7b31325e59e5dd15c9c4e4600b5e6700d0e1c (diff)
downloadaur-555bd455acfbe048cc69c3a991b7d84b2da7a5a4.tar.gz
fix building and correct the path to man pages
Looks like incorrect dependencies break parallel installation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6426f5b0bff3..1a826d2f7f4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gpac-git
pkgdesc = A multimedia framework based on the MPEG-4 Systems standard (git version)
- pkgver = 0.5.2.r3540.g96ec5b596
+ pkgver = 0.5.2.r3552.ge1fa8f051
pkgrel = 2
epoch = 1
url = https://gpac.wp.imt.fr/
@@ -24,7 +24,7 @@ pkgbase = gpac-git
optdepends = faad2: for AAC support
optdepends = libmad: for mp3 support
optdepends = sdl2: for sdl support
- provides = gpac=0.5.2.r3540.g96ec5b596
+ provides = gpac=0.5.2.r3552.ge1fa8f051
conflicts = gpac
source = git+https://github.com/gpac/gpac.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aada0cdb381a..9d4961915b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=gpac
pkgname=$_pkgname-git
-pkgver=0.5.2.r3540.g96ec5b596
+pkgver=0.5.2.r3552.ge1fa8f051
pkgrel=2
epoch=1
pkgdesc="A multimedia framework based on the MPEG-4 Systems standard (git version)"
@@ -32,11 +32,14 @@ pkgver() {
build() {
cd $_pkgname
- ./configure --prefix=/usr --use-js=no
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --use-js=no
make
}
package() {
cd $_pkgname
- make DESTDIR="$pkgdir" install install-lib
+ make DESTDIR="$pkgdir" -j1 install install-lib
}