summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:49:12 -0600
committerBrian Bidulock2015-06-10 05:49:12 -0600
commit73134bae0a859e0d5176b84070ae474e15b4ec7e (patch)
tree00e2f380bfcfde99a5f70799a17e1f986c0c3e83
downloadaur-73134bae0a859e0d5176b84070ae474e15b4ec7e.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--gpaint.desktop11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8217d324ea64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gpaint
+ pkgdesc = A small easy-to-use paint program for the GNOME Desktop
+ pkgver = 0.3.3
+ pkgrel = 12
+ url = http://savannah.gnu.org/projects/gpaint/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = libglade
+ depends = gdk-pixbuf2
+ source = ftp://alpha.gnu.org/gnu/gpaint/gpaint-2-0.3.3.tar.gz
+ source = fill.patch::https://savannah.gnu.org/patch/download.php?file_id=19341
+ source = gpaint.desktop
+ sha256sums = 541706460610c8bd917225a0370762b66e378e756afa780e67677eeb0a2dd0eb
+ sha256sums = d8600339f2a53e21c46e150e29817f1f999d8963859712d2f988b38687ebb2a5
+ sha256sums = c4ccd43e1343befa8cfcca0e644fd2268315b328277346ebf236260e467d62cd
+
+pkgname = gpaint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abb570f12b96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Aaditya Bagga <aaditya_gnulinux@zoho.com>
+
+pkgname=gpaint
+pkgver=0.3.3
+pkgrel=12
+pkgdesc="A small easy-to-use paint program for the GNOME Desktop"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('libglade' 'gdk-pixbuf2')
+url="http://savannah.gnu.org/projects/gpaint/"
+source=("ftp://alpha.gnu.org/gnu/$pkgname/$pkgname-2-$pkgver.tar.gz"
+ 'fill.patch::https://savannah.gnu.org/patch/download.php?file_id=19341'
+ "$pkgname.desktop")
+sha256sums=('541706460610c8bd917225a0370762b66e378e756afa780e67677eeb0a2dd0eb'
+ 'd8600339f2a53e21c46e150e29817f1f999d8963859712d2f988b38687ebb2a5'
+ 'c4ccd43e1343befa8cfcca0e644fd2268315b328277346ebf236260e467d62cd')
+
+prepare() {
+ cd "$pkgname-2-$pkgver"
+ sed -i 's#GTK_RESPONSE_DISCARD#GTK_RESPONSE_NO#' src/drawing.c
+ patch -p1 -i $srcdir/fill.patch
+}
+
+build() {
+ cd "$pkgname-2-$pkgver"
+ ./configure --prefix=/usr
+ make LDFLAGS+="-lm"
+}
+
+package() {
+ cd "$pkgname-2-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "$pkgdir/usr/bin/$pkgname-2" "$pkgdir/usr/bin/$pkgname"
+ rm "$pkgdir/usr/bin/$pkgname-2"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gpaint.desktop b/gpaint.desktop
new file mode 100644
index 000000000000..844f5442d199
--- /dev/null
+++ b/gpaint.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=GNU Paint
+Comment=A small-scale painting program for GNOME, the GNU Desktop
+Comment[fr]=Un petit outil de dessin pour GNOME, le desktop GNU
+Comment[pt_BR]=Um pequeno programa de desenho para o GNOME, o Desktop GNU
+TryExec=gpaint
+Exec=gpaint
+Icon=gnome-logo-icon-transparent
+Terminal=false
+Type=Application
+Categories=Graphics;