summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-05-13 01:04:48 +0200
committerMarcin Wieczorek2016-05-13 01:04:48 +0200
commit5357bcc254fd87c7ef70dd75a744b4e79e7c4e82 (patch)
tree09ad2500906a56942fbded2f6bcb8e80c1c8d9a4
parent34583cc3af398374b510d48bb9143e46c05c9caf (diff)
downloadaur-5357bcc254fd87c7ef70dd75a744b4e79e7c4e82.tar.gz
Version 3.20
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a0c09d1bd81..bfd6131f0ff7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gpaste-daemon
pkgdesc = A clipboard management daemon
- pkgver = 3.16.2.1
+ pkgver = 3.20
pkgrel = 1
url = http://www.imagination-land.org/tags/GPaste.html
install = gpaste-daemon.install
@@ -12,13 +12,14 @@ pkgbase = gpaste-daemon
depends = gtk3
depends = systemd
depends = xcb-util-keysyms
+ depends = appstream-glib
provides = gpaste
conflicts = cinnamon-extension-gpaste
conflicts = gpaste
options = !emptydirs
options = !libtool
- source = http://www.imagination-land.org/files/gpaste/gpaste-3.16.2.1.tar.xz
- md5sums = 935b66abf61e1a0d6385acdbecbb8134
+ source = http://www.imagination-land.org/files/gpaste/gpaste-3.20.tar.xz
+ md5sums = ae4bc3b07cc943d3640108687050900a
pkgname = gpaste-daemon
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b63977a0ed66
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 4fcb24f52d46..0355de78da63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Contributor : Yamashita Ren
-# Contributor : Ner0
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: Yamashita Ren
+# Contributor: Ner0
pkgname=gpaste-daemon
-pkgver=3.16.2.1
+pkgver=3.20
pkgrel=1
pkgdesc="A clipboard management daemon"
arch=('i686' 'x86_64')
url="http://www.imagination-land.org/tags/GPaste.html"
license=('GPL3')
-depends=('gtk3' 'systemd' 'xcb-util-keysyms')
+depends=('gtk3' 'systemd' 'xcb-util-keysyms' 'appstream-glib')
makedepends=('gobject-introspection' 'intltool')
conflicts=('cinnamon-extension-gpaste' 'gpaste')
provides=('gpaste')
options=('!emptydirs' '!libtool')
install=$pkgname.install
source=("http://www.imagination-land.org/files/gpaste/gpaste-$pkgver.tar.xz")
-md5sums=('935b66abf61e1a0d6385acdbecbb8134')
+md5sums=('ae4bc3b07cc943d3640108687050900a')
build () {
- cd ${pkgname%-*}-${pkgver}
+ cd ${pkgname%-*}-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --disable-applet --disable-gnome-shell-extension \
- --without-controlcenterdir --disable-schemas-compile --disable-vala
- make
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --disable-applet --disable-gnome-shell-extension --without-controlcenterdir --disable-schemas-compile --disable-vala
+ make
}
package () {
- cd ${pkgname%-*}-${pkgver}
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname%-*}-${pkgver}
+ make DESTDIR="$pkgdir/" install
- install -Dpm644 data/completions/gpaste "$pkgdir/etc/bash_completion.d/gpaste"
- install -Dpm644 data/completions/_gpaste "$pkgdir/usr/share/zsh/site-functions/_gpaste"
- rm -rf "$pkgdir/no"
+ install -Dpm644 data/completions/gpaste-client "$pkgdir/etc/bash_completion.d/gpaste-client"
+ install -Dpm644 data/completions/_gpaste-client "$pkgdir/usr/share/zsh/site-functions/_gpaste-client"
+ rm -rf "$pkgdir/no"
}